summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/google-apputils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/google-apputils')
-rw-r--r--dev-python/google-apputils/Manifest2
-rw-r--r--dev-python/google-apputils/google-apputils-0.4.0.ebuild43
-rw-r--r--dev-python/google-apputils/google-apputils-0.4.2.ebuild33
-rw-r--r--dev-python/google-apputils/metadata.xml9
4 files changed, 87 insertions, 0 deletions
diff --git a/dev-python/google-apputils/Manifest b/dev-python/google-apputils/Manifest
new file mode 100644
index 000000000000..c5ceafabb5a2
--- /dev/null
+++ b/dev-python/google-apputils/Manifest
@@ -0,0 +1,2 @@
+DIST google-apputils-0.4.0.tar.gz 80014 SHA256 b260eb39f2723b71329ad016773033b95a31e89d8c9e13b8e6a1ef8eed8e94a3 SHA512 5dbbf50e9551b33d882557ef9385c64691dcff6d6c219c9ff6aea2dc73c8af6d03392b3088fe1fb4000979e227830a0e437dc347520488627657085c8ea23f5e WHIRLPOOL c52d3fb5a4b0a81f212f53e4e1c92efee1275415fdb6ac337bce18494cee5a9c319c07634f890187e3e9f6b7d9222da048dc484d18fde6727db569d7c579d27f
+DIST google-apputils-0.4.2.tar.gz 81095 SHA256 47959d0651c32102c10ad919b8a0ffe0ae85f44b8457ddcf2bdc0358fb03dc29 SHA512 d7579ec461292bb01ad5b8e1b09e161c66af0e85361f43f6065b837c90bddb9711a2d56db2b73d780dc25945375d4dad2f646507512b9acfeefd517613feacd4 WHIRLPOOL d5db6aeebb18b9b3a01dbb338095a3b3b90fc90c9cb2250f141e07426119dada1deb301f4d9c3580448709d329de86f7086e13a6ab479ab1e8da154d53f921bc
diff --git a/dev-python/google-apputils/google-apputils-0.4.0.ebuild b/dev-python/google-apputils/google-apputils-0.4.0.ebuild
new file mode 100644
index 000000000000..308acfad3f83
--- /dev/null
+++ b/dev-python/google-apputils/google-apputils-0.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 ) # Doesn't yet support py3
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of utilities for building Python applications"
+HOMEPAGE="http://code.google.com/p/google-apputils-python/"
+SRC_URI="http://google-apputils-python.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ~ia64 ~m68k ~mips ~ppc64 ~s390 ~sh x86"
+IUSE="test"
+
+RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-gflags[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/mox[${PYTHON_USEDEP}] )"
+# version borders needed are already confluent with versions in the tree
+
+python_prepare_all() {
+ # https://code.google.com/p/google-apputils-python/source/detail?r=12
+ # This version bordering is long out of date and wrong since end of March 2012!
+ sed -e 's:>=1.4,<2:>=1.4:' -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # These yield 2 fails which are in fact expected errors run from a shell script!
+ # They seemingly have no immediate mechanism to exit 0 in an expected fail style.
+ for test in tests/{app_test*.py,[b-s]*.py}
+ do
+ "${PYTHON}" $test || die "test failure under ${EPYTHON}"
+ done
+}
diff --git a/dev-python/google-apputils/google-apputils-0.4.2.ebuild b/dev-python/google-apputils/google-apputils-0.4.2.ebuild
new file mode 100644
index 000000000000..055a248b970c
--- /dev/null
+++ b/dev-python/google-apputils/google-apputils-0.4.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 ) # Doesn't yet support py3
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of utilities for building Python applications"
+HOMEPAGE="https://github.com/google/google-apputils"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc64 ~s390 ~sh ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/python-dateutil-1.4[${PYTHON_USEDEP}]
+ >=dev-python/python-gflags-1.4[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2010[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} dev-python/mox[${PYTHON_USEDEP}] )"
+
+python_test() {
+ # These yield 2 fails which are in fact expected errors run from a shell script!
+ # They seemingly have no immediate mechanism to exit 0 in an expected fail style.
+ for test in tests/{app_test*.py,[b-s]*.py} ; do
+ "${PYTHON}" $test || die "test failure under ${EPYTHON}"
+ done
+}
diff --git a/dev-python/google-apputils/metadata.xml b/dev-python/google-apputils/metadata.xml
new file mode 100644
index 000000000000..f6092835c804
--- /dev/null
+++ b/dev-python/google-apputils/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="github">google/google-apputils</remote-id>
+ <remote-id type="pypi">google-apputils</remote-id>
+ </upstream>
+</pkgmetadata>