summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-15 22:55:27 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-15 22:55:27 +0100
commit1c69018a26d6dcc3cfa6178a992ab40b075de6dc (patch)
tree57bd80e891d953e2ad6d1d82b5461fff42c4b2e7 /dev-python/graphviz
parentdev-python/pytest-mock: remove unused patch(es) (diff)
downloadgentoo-1c69018a26d6dcc3cfa6178a992ab40b075de6dc.tar.gz
gentoo-1c69018a26d6dcc3cfa6178a992ab40b075de6dc.tar.bz2
gentoo-1c69018a26d6dcc3cfa6178a992ab40b075de6dc.zip
dev-python/graphviz: Bump to 0.15
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/graphviz')
-rw-r--r--dev-python/graphviz/Manifest1
-rw-r--r--dev-python/graphviz/graphviz-0.15.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/graphviz/Manifest b/dev-python/graphviz/Manifest
index 0892bc77f76f..92fee8679bd4 100644
--- a/dev-python/graphviz/Manifest
+++ b/dev-python/graphviz/Manifest
@@ -1 +1,2 @@
DIST graphviz-0.14.2.zip 184157 BLAKE2B 668c200964867f416e2b15454793fdd0673a110461a85764699727b0430c812e18fb4285e031f5f611ff86bd205cbf927c695015d55ac169a594e616ab74067a SHA512 a8bcf395ebed7c43f5355bc167aae157c6eddb127860a6fb58eba0d882235e04a33a5bcf589245f484e3af9dce5eff8a5893ced73203901c92afd92c4f5b05be
+DIST graphviz-0.15.zip 183103 BLAKE2B 81d4a121ca2654e6c08570ede7a1f5ef580b6a281358bf32f4178898fc12cfae21b10ce8f4f6fba4644e3275162cc09dbf5ae287a114fb8503be98d6a2fbf728 SHA512 c2a77f0d52595a70b4f8ccd906907453b59622560f0ff84e267e874f5a1dc9a4b721192d236b0519ee7ec85bae9b225b9919ae51bcf599c93bd5816934afd6cc
diff --git a/dev-python/graphviz/graphviz-0.15.ebuild b/dev-python/graphviz/graphviz-0.15.ebuild
new file mode 100644
index 000000000000..3700d1003cf8
--- /dev/null
+++ b/dev-python/graphviz/graphviz-0.15.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple Python interface for Graphviz"
+HOMEPAGE="https://graphviz.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="media-gfx/graphviz"
+BDEPEND="
+ app-arch/unzip
+ test? ( ${RDEPEND}
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.8[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:--cov --cov-report=term --cov-report=html::' \
+ -i setup.cfg || die
+ distutils-r1_src_prepare
+}