summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/hiredis
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/hiredis')
-rw-r--r--dev-python/hiredis/Manifest2
-rw-r--r--dev-python/hiredis/files/hiredis-0.1.1-system-libs.patch25
-rw-r--r--dev-python/hiredis/files/hiredis-0.2.0-system-libs.patch28
-rw-r--r--dev-python/hiredis/hiredis-0.1.1-r2.ebuild23
-rw-r--r--dev-python/hiredis/hiredis-0.2.0.ebuild29
-rw-r--r--dev-python/hiredis/metadata.xml13
6 files changed, 120 insertions, 0 deletions
diff --git a/dev-python/hiredis/Manifest b/dev-python/hiredis/Manifest
new file mode 100644
index 000000000000..f196e32b98f6
--- /dev/null
+++ b/dev-python/hiredis/Manifest
@@ -0,0 +1,2 @@
+DIST hiredis-0.1.1.tar.gz 35598 SHA256 ca7b3840d12f836dabfd73708bd64c0ac31204b22a926279b6515e6433e50ffc SHA512 fe588927698e771a3efb5918c2de308e435b1052b7991d331b4c59976a48ba42be0711bab4546d6aac19d851c6eb829c1208ff403f5e447c4201dc9c83aebc20 WHIRLPOOL e9e8b79e6f054e60f7eb0911123ce96e2cb3870378aa710b87c8604a22df4b3aa5a0b123970736d900a507eb5ee4e33858b4af170a776fdf01642e37b171a607
+DIST hiredis-0.2.0.tar.gz 46113 SHA256 ca958e13128e49674aa4a96f02746f5de5973f39b57297b84d59fd44d314d5b5 SHA512 9eb18ec089517340043d14938a213b139dc948dc9cf2f9c65e632bb4694ac22543b87a5875c1cea083e2bc8e303103c749047889cdb3e9d5680b586d34330c86 WHIRLPOOL 5c2252d82814b8365a29160c41133571083954c317f9c36f534e3f0aa98bc97621f144479b715da0d5c77a0a00a7a5e0b69fb63c2559a4ebf124d88be93d477d
diff --git a/dev-python/hiredis/files/hiredis-0.1.1-system-libs.patch b/dev-python/hiredis/files/hiredis-0.1.1-system-libs.patch
new file mode 100644
index 000000000000..298f5cf7ee2e
--- /dev/null
+++ b/dev-python/hiredis/files/hiredis-0.1.1-system-libs.patch
@@ -0,0 +1,25 @@
+--- hiredis-0.1.1/setup.py
++++ hiredis-0.1.1/setup.py
+@@ -20,13 +20,9 @@
+ if self.distribution.has_ext_modules():
+ self.run_command('build_ext')
+
+-lib = ("hiredis", {
+- "sources": ["vendor/hiredis/%s.c" % src for src in ("hiredis", "net", "sds")],
+- "include_dirs": ["vendor/hiredis"]})
+-
+ ext = Extension("hiredis.hiredis",
+ sources=glob.glob("src/*.c"),
+- include_dirs=["src", "vendor"],
++ include_dirs=["src"],
+ libraries=["hiredis"])
+
+ setup(
+@@ -39,7 +35,6 @@
+ keywords=["Redis"],
+ license="BSD",
+ packages=["hiredis"],
+- libraries=[lib],
+ ext_modules=[ext],
+
+ # Override "install_lib" command
diff --git a/dev-python/hiredis/files/hiredis-0.2.0-system-libs.patch b/dev-python/hiredis/files/hiredis-0.2.0-system-libs.patch
new file mode 100644
index 000000000000..6cd22292deb9
--- /dev/null
+++ b/dev-python/hiredis/files/hiredis-0.2.0-system-libs.patch
@@ -0,0 +1,28 @@
+Remove vendor and var 'lib' from setup.py
+diff -u hiredis-0.2.0.orig/setup.py hiredis-0.2.0/setup.py
+--- setup.py 2015-06-21 11:47:28.796472027 +0800
++++ setup.py 2015-06-21 11:49:53.047949803 +0800
+@@ -40,12 +40,9 @@
+ # supported Python versions is worse...
+ #
+ # Also see: https://github.com/pietern/hiredis-py/issues/15
+-lib = ("hiredis_for_hiredis_py", {
+- "sources": ["vendor/hiredis/%s.c" % src for src in ("read", "sds")]})
+
+ ext = Extension("hiredis.hiredis",
+- sources=glob.glob("src/*.c"),
+- include_dirs=["vendor"])
++ sources=glob.glob("src/*.c"))
+
+ setup(
+ name="hiredis",
+@@ -57,7 +54,6 @@
+ keywords=["Redis"],
+ license="BSD",
+ packages=["hiredis"],
+- libraries=[lib],
+ ext_modules=[ext],
+
+ # Override "install_lib" command
+Common subdirectories: hiredis-0.2.0.orig/src and hiredis-0.2.0/src
+Common subdirectories: hiredis-0.2.0.orig/vendor and hiredis-0.2.0/vendor
diff --git a/dev-python/hiredis/hiredis-0.1.1-r2.ebuild b/dev-python/hiredis/hiredis-0.1.1-r2.ebuild
new file mode 100644
index 000000000000..65a7699394ee
--- /dev/null
+++ b/dev-python/hiredis/hiredis-0.1.1-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python extension that wraps hiredis"
+HOMEPAGE="https://github.com/pietern/hiredis-py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE=""
+
+DEPEND="dev-libs/hiredis"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-system-libs.patch )
diff --git a/dev-python/hiredis/hiredis-0.2.0.ebuild b/dev-python/hiredis/hiredis-0.2.0.ebuild
new file mode 100644
index 000000000000..0354d86ef3fa
--- /dev/null
+++ b/dev-python/hiredis/hiredis-0.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python extension that wraps hiredis"
+HOMEPAGE="https://github.com/pietern/hiredis-py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/hiredis-0.13.1"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-system-libs.patch )
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+ distutils-r1_python_compile
+}
diff --git a/dev-python/hiredis/metadata.xml b/dev-python/hiredis/metadata.xml
new file mode 100644
index 000000000000..3702b96a3b38
--- /dev/null
+++ b/dev-python/hiredis/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>swegener@gentoo.org</email>
+ <name>Sven Wegener</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">hiredis</remote-id>
+ <remote-id type="github">pietern/hiredis-py</remote-id>
+ </upstream>
+</pkgmetadata>