summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-07-25 01:01:36 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-07-25 01:03:55 +0200
commitdaae984a63909f554dc8ee40d69891e821f3c1fc (patch)
tree4582249a48da3b1da847511738076a878ca16ee6 /dev-python/httpstat/httpstat-1.2.1-r1.ebuild
parentdev-python/denonavr: add Python 3.7, make tests more verbose (diff)
downloadgentoo-daae984a63909f554dc8ee40d69891e821f3c1fc.tar.gz
gentoo-daae984a63909f554dc8ee40d69891e821f3c1fc.tar.bz2
gentoo-daae984a63909f554dc8ee40d69891e821f3c1fc.zip
dev-python/httpstat: Add missing dev-python/setuptools dependency
Closes: https://bugs.gentoo.org/662020 Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-python/httpstat/httpstat-1.2.1-r1.ebuild')
-rw-r--r--dev-python/httpstat/httpstat-1.2.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/httpstat/httpstat-1.2.1-r1.ebuild b/dev-python/httpstat/httpstat-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..46805fd97fb3
--- /dev/null
+++ b/dev-python/httpstat/httpstat-1.2.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="httpstat visualizes cURL statistics in a way of beauty and clarity"
+HOMEPAGE="https://github.com/reorx/httpstat"
+SRC_URI="https://github.com/reorx/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="net-misc/curl:*"
+
+# Requires access to google.com and http2.akamai.com
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.2.1-gentoo-tests.patch )
+
+python_test() {
+ ./httpstat_test.sh || die
+}