summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-03 21:05:02 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-03 21:55:54 +0200
commitc7899e217250ead7aced220acc90527987c23432 (patch)
tree90129e57cc916343ca2038c92a665fb06555499c /dev-python/huawei-lte-api
parentdev-python/cattrs: Bump to 22.2.0 (diff)
downloadgentoo-c7899e217250ead7aced220acc90527987c23432.tar.gz
gentoo-c7899e217250ead7aced220acc90527987c23432.tar.bz2
gentoo-c7899e217250ead7aced220acc90527987c23432.zip
dev-python/huawei-lte-api: Bump to 1.6.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/huawei-lte-api')
-rw-r--r--dev-python/huawei-lte-api/Manifest1
-rw-r--r--dev-python/huawei-lte-api/huawei-lte-api-1.6.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/huawei-lte-api/Manifest b/dev-python/huawei-lte-api/Manifest
index 95609d0fcead..bc7255c97eac 100644
--- a/dev-python/huawei-lte-api/Manifest
+++ b/dev-python/huawei-lte-api/Manifest
@@ -1 +1,2 @@
DIST huawei-lte-api-1.6.1.gh.tar.gz 32963 BLAKE2B f159e1dc4cb759c09a88bb763c6ba5f43043eacf025e7ada871c816e0e72a238f9e7536dbc043f8596bef390ecfc2ee137c1a4c079ca33db6c3a3198147c9f98 SHA512 2a6a330c419af0d2b8eeff9d8b93a11cdf8050db04e609cb1d86a33ab770d7102c8e40652482c2500ce4bf4152b66b98ee1fc77be104db8ab9a9bbeec871ce20
+DIST huawei-lte-api-1.6.3.gh.tar.gz 33065 BLAKE2B 2c16080b929d410d0e05b028e8a73003e5dd0b8a5e14602173571b473ffdcfc8ffb742b3db23dc7d4892386447d9c8fa9b30eee4016aa8f94ec7ac878184ca88 SHA512 a48c56d88859ef8a12eebaed48787fe7b62e3abac9b1d393e70dff9553b51284a5b860e113f4ed709dcab590c607a356c3b3fb81ac7bce5260fdf21d28d98510
diff --git a/dev-python/huawei-lte-api/huawei-lte-api-1.6.3.ebuild b/dev-python/huawei-lte-api/huawei-lte-api-1.6.3.ebuild
new file mode 100644
index 000000000000..5b62e249fda3
--- /dev/null
+++ b/dev-python/huawei-lte-api/huawei-lte-api-1.6.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="API For huawei LAN/WAN LTE Modems"
+HOMEPAGE="
+ https://github.com/Salamek/huawei-lte-api/
+ https://pypi.org/project/huawei-lte-api/
+"
+SRC_URI="
+ https://github.com/Salamek/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # make cryptodome-friendly
+ sed -i -e 's:pycryptodomex:pycryptodome:' setup.py || die
+ find -name '*.py' -exec \
+ sed -i -e 's:Cryptodome:Crypto:g' {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+distutils_enable_tests pytest