summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2021-03-02 22:35:08 +0100
committerAgostino Sarubbo <ago@gentoo.org>2021-03-02 22:35:13 +0100
commite2ab36d07a09f2ef1fca28b6b493f616858a4fab (patch)
tree32f82c960f2869f5eec70f7002476bf22a15afb2 /dev-python/huawei-lte-api
parentwww-apps/chromedriver-bin: bump to 89.0.4389.23 (diff)
downloadgentoo-e2ab36d07a09f2ef1fca28b6b493f616858a4fab.tar.gz
gentoo-e2ab36d07a09f2ef1fca28b6b493f616858a4fab.tar.bz2
gentoo-e2ab36d07a09f2ef1fca28b6b493f616858a4fab.zip
dev-python/huawei-lte-api: initial import
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'dev-python/huawei-lte-api')
-rw-r--r--dev-python/huawei-lte-api/Manifest1
-rw-r--r--dev-python/huawei-lte-api/huawei-lte-api-1.4.17.ebuild30
-rw-r--r--dev-python/huawei-lte-api/metadata.xml12
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/huawei-lte-api/Manifest b/dev-python/huawei-lte-api/Manifest
new file mode 100644
index 000000000000..3cb8cdf775b5
--- /dev/null
+++ b/dev-python/huawei-lte-api/Manifest
@@ -0,0 +1 @@
+DIST huawei-lte-api-1.4.17.tar.gz 29441 BLAKE2B 75615092a1d8ee598a99e9ae7a0567e11a72fad21a8304005364bd21e4ecb9bf9efa9a2d5c8de86c6d7442ec12f06079819c20ca9e2e4646255ede961b1a1275 SHA512 bf4a6a43d02b56f0aa799e2936d7fd0afa88da4dc18c152c635b0ccb87a7ca9afcf1fcdee3a37d7ab232d5cd4688e24499ad35a1969d97db405b818cf17d33c4
diff --git a/dev-python/huawei-lte-api/huawei-lte-api-1.4.17.ebuild b/dev-python/huawei-lte-api/huawei-lte-api-1.4.17.ebuild
new file mode 100644
index 000000000000..0fe85aaad74c
--- /dev/null
+++ b/dev-python/huawei-lte-api/huawei-lte-api-1.4.17.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="API For huawei LAN/WAN LTE Modems"
+HOMEPAGE="https://github.com/Salamek/huawei-lte-api"
+SRC_URI="https://github.com/Salamek/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/dicttoxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # https://github.com/Salamek/huawei-lte-api/issues/86
+ sed "s:'pytest-runner'::" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+distutils_enable_tests pytest
diff --git a/dev-python/huawei-lte-api/metadata.xml b/dev-python/huawei-lte-api/metadata.xml
new file mode 100644
index 000000000000..7c8d9faf0487
--- /dev/null
+++ b/dev-python/huawei-lte-api/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ago@gentoo.org</email>
+ <name>Agostino Sarubbo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Salamek/huawei-lte-api</remote-id>
+ <remote-id type="pypi">huawei-lte-api</remote-id>
+ </upstream>
+</pkgmetadata>