summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-09 22:23:29 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-09 22:53:57 +0200
commit07d2c1da4d965ce0aae27597c152632764fef3f3 (patch)
tree9b99d1c21324bea601a2b4aa8ffd5821823b98da /dev-python/hypothesis
parentdev-python/rich: Bump to 10.3.0 (diff)
downloadgentoo-07d2c1da4d965ce0aae27597c152632764fef3f3.tar.gz
gentoo-07d2c1da4d965ce0aae27597c152632764fef3f3.tar.bz2
gentoo-07d2c1da4d965ce0aae27597c152632764fef3f3.zip
dev-python/hypothesis: Bump to 6.14.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.14.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 435e91e3b359..fb706363efce 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -12,3 +12,4 @@ DIST hypothesis-python-6.13.6.tar.gz 9132027 BLAKE2B 939c7b410bef3d8e38a513e55f4
DIST hypothesis-python-6.13.7.tar.gz 9132167 BLAKE2B a7f58630d114743a04665d245384d3b5f6a0592d03a9b7e771ceb3ad8633fdd9c437dc6fa099d9dc48225d5d113a203a62ca29f50ff76fdbeb406f2cc63f9013 SHA512 70022d90c09f9478df94986059cbb986e35cb24d3a8c19d023a5a78c9e12982e196d258149456d6d2f01646e84a5ef07714f1967c6b31b53ad5e41ab2b5375d3
DIST hypothesis-python-6.13.8.tar.gz 9132344 BLAKE2B 8de45b42711f39fc6f08f0621ba0de5977bb10d623f08565840ce7b922a7049adf29c3f9315f4c2515229a9b7419d0671112562afe1065a156bc4685ffaa92f6 SHA512 a1fe1bdfac6694ecbbe6cd0d7e3d04766d9be812ea637c6b5755fbbaceda326300043b340558c80f082460e606742b0075a751f0f9cd8edc61fd8da947bda9f8
DIST hypothesis-python-6.13.9.tar.gz 9132354 BLAKE2B d0c9676d25e13c147ede7c6e5dd2d234f2e4fa6809dabe26d392101683dc5eb8fa14d63b7127d82dd93debf7d10848b2faca30912d9782adba7f116c10398575 SHA512 0e5df60f32ee8cd56a376bceffe39d28abb2e1fe9e190d452272e86e8f86162d6e262cd1d008c3635c12c60efaf258cfa379daf1de32e77a6470e41becda1363
+DIST hypothesis-python-6.14.0.tar.gz 9135056 BLAKE2B 47d1efcee5e1c4037f1a20f08e3bc873fc143a2182bbde07e897812622c4d68923f78ac356bd97ef541566a27a874705eb2438747daaebe84f95fc2a2262bac1 SHA512 f7821449d3bf7f3656b52dad09027e40ea4af1779fcc7c0b995dac55843953fdab3f2ba69eb1b8de8258616f49cf8e5098c6a222d01071916c6f0c9fe184c80b
diff --git a/dev-python/hypothesis/hypothesis-6.14.0.ebuild b/dev-python/hypothesis/hypothesis-6.14.0.ebuild
new file mode 100644
index 000000000000..004d0d143b20
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.14.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!dev-python/pytest-describe
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3_{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}