summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-10-11 18:50:16 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2020-10-12 17:49:46 +0200
commit72ea7287a6cbad119c5b86648dc2da51e0e774bc (patch)
tree915c1dab0edfbdcf5338ba3d7adc06464034a21b /dev-python/imread/imread-0.7.3.ebuild
parentdev-erlang/xmpp: Remove old (diff)
downloadgentoo-72ea7287a6cbad119c5b86648dc2da51e0e774bc.tar.gz
gentoo-72ea7287a6cbad119c5b86648dc2da51e0e774bc.tar.bz2
gentoo-72ea7287a6cbad119c5b86648dc2da51e0e774bc.zip
dev-python/imread: new ebuild
Signed-off-by: Dennis Lamm <expeditoneer@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/17890 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'dev-python/imread/imread-0.7.3.ebuild')
-rw-r--r--dev-python/imread/imread-0.7.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/imread/imread-0.7.3.ebuild b/dev-python/imread/imread-0.7.3.ebuild
new file mode 100644
index 000000000000..bf90e09c7893
--- /dev/null
+++ b/dev-python/imread/imread-0.7.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read Image Files"
+HOMEPAGE="http://luispedro.org/software/imread/ https://github.com/luispedro/imread"
+SRC_URI="https://github.com/luispedro/imread/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs \
+ 'dev-python/numpydoc'
+
+distutils_enable_tests setup.py