summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-19 12:58:56 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-03-27 18:24:59 +0200
commit904462ef1af33287a4a3fcff593b80a3f073d8e5 (patch)
tree91db31416017f3207452820799e09ae0cca5eacf /dev-python/jedi
parentsci-biology/foldingathome: revert init fix (diff)
downloadgentoo-904462ef1af33287a4a3fcff593b80a3f073d8e5.tar.gz
gentoo-904462ef1af33287a4a3fcff593b80a3f073d8e5.tar.bz2
gentoo-904462ef1af33287a4a3fcff593b80a3f073d8e5.zip
dev-python/jedi: Version bump 0.15.2
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/jedi')
-rw-r--r--dev-python/jedi/Manifest1
-rw-r--r--dev-python/jedi/jedi-0.15.2.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/jedi/Manifest b/dev-python/jedi/Manifest
index 94d45257b3f0..97610ddd6cc0 100644
--- a/dev-python/jedi/Manifest
+++ b/dev-python/jedi/Manifest
@@ -4,4 +4,5 @@ DIST jedi-0.12.0.tar.gz 354329 BLAKE2B ef203f2ba57a90de1e16b80c8786fa25d6d459244
DIST jedi-0.12.1.tar.gz 356736 BLAKE2B 515cbc27e065c24fb2cebae5a3807d2e025f22110f3de60d26a74475eadc985bb32bea60b691c580473fffe2fdfc86705187dea1fb730ef3f510b7bdb52e0d59 SHA512 92f9ac34abf908a8143dff360400dd8d6643dc3502bb7973f92bd05db94c2af151c2063f2de0481a14e26d11c009cc39c46189e1ea31d274b80802e3a10cd665
DIST jedi-0.14.1.tar.gz 860206 BLAKE2B d1234ceb417f531c5a29908843a47bec5b198abbc848248517f2796d95319e2d930f7c01af9759cb9a3d44a28fb73c4080802642aea1be32f16689e76c1a49ce SHA512 d68c350259921792788917440c9dd6eb923c90eb1b8d0e078a6d428fad852c4d6bbdc74d8caa88ba5a87db344e4b372dc9cfc959d7bab922888d70402fcf4776
DIST jedi-0.15.1.tar.gz 412356 BLAKE2B a7738e8825b3f578db5e64d50cbf65219b4d2f2f81c45cbae9e3dbb858b0e1ef26d76972c112bfae839daaf73bba0d00b30b5708404d16b0385452500a1c2d35 SHA512 0f6e0185f3f10dbc000f09ddfed7b9596fe5dc270682544173dc156d505618ea14f1f44ede5d2357745ab8ded0b15b2788d064ca4db39fe70196982dd0a16893
+DIST jedi-0.15.2.tar.gz 422520 BLAKE2B f382e4026e1d0388c03b5116ea49fe4abf117c1555ccf0159541557e8d0d344774e15b983fbc66f996f60ae38552bb3b89f3f9cc809ab57f511a01664612f08f SHA512 079d9fc104125d188c72cfc0bd0ccd4de88eb5e7cdfba86e44f840e2427d0ab114bb812dad8e814e502e773d3a59f166547f5f6f287a5eedae64af99e8b5616e
DIST typeshed-jedi_v0.15.0.tar.gz 466890 BLAKE2B 7c4956c60646ecb7f21704e3ce95cd38a44e40849e4efba352a0be11c4511fc28d77f32308a3f136cd72833f937f802194ae57f1cdf1d53ae7824ebe4f4bc323 SHA512 46250822eb4aa20203db9b99626e33f2b60ec77072e20dbd94219d782cf204e2cc5a94579b1753c634f931445ad4ef9f0bd7ccfed287d86bca96b945d2eb27c1
diff --git a/dev-python/jedi/jedi-0.15.2.ebuild b/dev-python/jedi/jedi-0.15.2.ebuild
new file mode 100644
index 000000000000..3cd8bc1d3369
--- /dev/null
+++ b/dev-python/jedi/jedi-0.15.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+TYPESHED_PV="$(ver_cut 1-2).0"
+TYPESHED_P="typeshed-jedi_v${TYPESHED_PV}"
+
+DESCRIPTION="Autocompletion library for Python"
+HOMEPAGE="https://github.com/davidhalter/jedi"
+SRC_URI="https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/davidhalter/typeshed/archive/${TYPESHED_P#typeshed-}.tar.gz -> ${TYPESHED_P}.tar.gz"
+
+LICENSE="MIT
+ test? ( Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND=">=dev-python/parso-0.5.2[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # upstream includes this as a submodule ...
+ rmdir "${S}/jedi/third_party/typeshed" || die
+ mv "${WORKDIR}/${TYPESHED_P}" \
+ "${S}/jedi/third_party/typeshed" || die
+
+ # don't run doctests, don't depend on colorama
+ sed -i "s:'docopt',:: ; s:'colorama',::" setup.py || die
+ sed -i "s: --doctest-modules::" pytest.ini || die
+
+ # speed tests are fragile
+ rm test/test_speed.py || die
+
+ # Test <IntegrationTestCase: /var/tmp/portage/dev-python/jedi-0.15.2/work/jedi-0.15.2/test/completion/stdlib.py:194 ' c'> failed.
+ rm test/completion/stdlib.py || die
+
+ # Test <IntegrationTestCase: /var/tmp/portage/dev-python/jedi-0.15.2/work/jedi-0.15.2/test/completion/on_import.py:27 'import test'> failed.
+ rm test/completion/on_import.py || die
+
+ # ValueError: Should not happen. type: del_stmt
+ rm test/test_utils.py || die
+
+ # KeyError: ((), frozenset())
+ sed -i -e 's:test_os_nowait:_&:' test/test_api/test_completion.py || die
+ sed -i -e 's:test_os_issues:_&:' test/test_api/test_full_name.py || die
+
+ # AssertionError: assert 'staticmethod(f: Callable)' == 'staticmethod(f: Callable[..., Any])'
+ sed -i -e 's:test_staticmethod:_&:' test/test_api/test_signatures.py || die
+
+ # AssertionError: assert 'path' not in ['abc', 'aifc', 'aiocontextvars', 'aiohttp', 'aiohttp_cors', 'aiounittest', ...]
+ sed -i -e 's:test_os_issues:_&:' test/test_inference/test_imports.py || die
+
+ # ValueError: not enough values to unpack (expected 2, got 1)
+ sed -i -e 's:test_get_modules_containing_name:_&:' test/test_inference/test_docstring.py || die
+
+ # AssertionError
+ sed -i -e 's:test_venv_and_pths:_&:' test/test_inference/test_sys_path.py || die
+
+ # AssertionError
+ sed -i -e 's:test_get_typeshed_directories:_&:' test/test_inference/test_gradual/test_typeshed.py || die
+
+ distutils-r1_python_prepare_all
+}