summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-30 09:22:13 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-30 09:24:47 +0200
commitc81f64268832c3812f97569de766b64b21836344 (patch)
tree72162b16b292e0e475f93373e77a8b24d8b29866 /dev-python/jsonrpclib
parentdev-python/jsonrpclib: Bump to 0.4.0, py3.7, cleanup (diff)
downloadgentoo-c81f64268832c3812f97569de766b64b21836344.tar.gz
gentoo-c81f64268832c3812f97569de766b64b21836344.tar.bz2
gentoo-c81f64268832c3812f97569de766b64b21836344.zip
dev-python/jsonrpclib: Sync -9999
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonrpclib')
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-9999.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/dev-python/jsonrpclib/jsonrpclib-9999.ebuild b/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
index 8744005ec438..c7b359ea5372 100644
--- a/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
+++ b/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
inherit distutils-r1
@@ -19,12 +19,13 @@ HOMEPAGE="https://github.com/tcalmant/jsonrpclib"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE=""
+IUSE="test"
+RESTRICT="!test? ( test )"
-DEPEND=""
-RDEPEND="${DEPEND}
- dev-python/simplejson"
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
python_test() {
- esetup.py test || die "tests failed with ${EPYTHON}"
+ esetup.py test
}