summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-05 08:00:07 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-05 08:07:49 +0200
commita7a6b390d8814d55ada17930372dc8532bc2939b (patch)
tree56b180cc846b4925a1ea76bf5d30648cadf0e4bf /dev-python/jupyter/jupyter-1.0.0-r2.ebuild
parentdev-python/testfixtures: Bump to 6.14.2 (diff)
downloadgentoo-a7a6b390d8814d55ada17930372dc8532bc2939b.tar.gz
gentoo-a7a6b390d8814d55ada17930372dc8532bc2939b.tar.bz2
gentoo-a7a6b390d8814d55ada17930372dc8532bc2939b.zip
dev-python/jupyter: Revbump post py3.6 removal
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter/jupyter-1.0.0-r2.ebuild')
-rw-r--r--dev-python/jupyter/jupyter-1.0.0-r2.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/jupyter/jupyter-1.0.0-r2.ebuild b/dev-python/jupyter/jupyter-1.0.0-r2.ebuild
deleted file mode 100644
index c88927ac5ff2..000000000000
--- a/dev-python/jupyter/jupyter-1.0.0-r2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Jupyter metapackage. Install all the Jupyter components in one go"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="
- mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
- https://patch-diff.githubusercontent.com/raw/jupyter/jupyter/pull/198.patch -> ${P}-file-colision.patch
- "
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- dev-python/notebook[${PYTHON_USEDEP}]
- dev-python/qtconsole[${PYTHON_USEDEP}]
- dev-python/jupyter_console[${PYTHON_USEDEP}]
- dev-python/nbconvert[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/ipywidgets[${PYTHON_USEDEP}]"
-PDEPEND=">=dev-python/jupyter_core-4.2.0[${PYTHON_USEDEP}]"
-
-distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
-
-PATCHES=( "${DISTDIR}"/${P}-file-colision.patch )
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}