summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-13 16:57:51 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-13 17:45:57 +0300
commitbb9f2cad6b562d1800e1a2fc814a984938bdbb08 (patch)
tree00eebd02580a3776465aa8fb133c66c40c239dac /dev-python/lazy-object-proxy
parentBump to 1.1.84 (diff)
downloadgentoo-bb9f2cad6b562d1800e1a2fc814a984938bdbb08.tar.gz
gentoo-bb9f2cad6b562d1800e1a2fc814a984938bdbb08.tar.bz2
gentoo-bb9f2cad6b562d1800e1a2fc814a984938bdbb08.zip
dev-python/lazy-object-proxy: use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/lazy-object-proxy')
-rw-r--r--dev-python/lazy-object-proxy/lazy-object-proxy-1.7.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/lazy-object-proxy/lazy-object-proxy-1.7.1-r1.ebuild b/dev-python/lazy-object-proxy/lazy-object-proxy-1.7.1-r1.ebuild
new file mode 100644
index 000000000000..f0939d83d332
--- /dev/null
+++ b/dev-python/lazy-object-proxy/lazy-object-proxy-1.7.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A fast and thorough lazy object proxy"
+HOMEPAGE="
+ https://github.com/ionelmc/python-lazy-object-proxy
+ https://pypi.org/project/lazy-object-proxy/
+ https://python-lazy-object-proxy.readthedocs.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # No need to benchmark
+ sed \
+ -e '/benchmark/s:test_:_&:g' \
+ -e '/pytest.mark.benchmark/d' \
+ -i tests/test_lazy_object_proxy.py || die
+ distutils-r1_python_prepare_all
+}