summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-20 22:55:08 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-21 00:34:36 +0200
commit2b098bc830ca4bb37d75fd0295984157b07a71e8 (patch)
treeca7af5ed35f45aedf5ff9460e69389373e0a4dae /dev-python/lit
parentsys-devel/llvm: Bump -9999 to EAPI 7 (diff)
downloadgentoo-2b098bc830ca4bb37d75fd0295984157b07a71e8.tar.gz
gentoo-2b098bc830ca4bb37d75fd0295984157b07a71e8.tar.bz2
gentoo-2b098bc830ca4bb37d75fd0295984157b07a71e8.zip
dev-python/lit: Bump -9999 to EAPI 7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lit')
-rw-r--r--dev-python/lit/lit-9999.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-python/lit/lit-9999.ebuild b/dev-python/lit/lit-9999.ebuild
index 0f71b5bb84ce..48607eb9c905 100644
--- a/dev-python/lit/lit-9999.ebuild
+++ b/dev-python/lit/lit-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
inherit distutils-r1 git-r3 multiprocessing
@@ -35,6 +35,7 @@ src_unpack() {
}
python_test() {
+ local -x LIT_PRESERVES_TMP=1
./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \
-vv tests || die
}