summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-07 15:59:56 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-07 15:59:56 +0100
commite352961e44bd1b04d2e52bb596fbd64b403290e2 (patch)
treed6eb83483cc8eced54720c645350aef9034f011e /dev-python/llfuse
parentdev-python/socketpool: Remove redundant versions (diff)
downloadgentoo-e352961e44bd1b04d2e52bb596fbd64b403290e2.tar.gz
gentoo-e352961e44bd1b04d2e52bb596fbd64b403290e2.tar.bz2
gentoo-e352961e44bd1b04d2e52bb596fbd64b403290e2.zip
dev-python/llfuse: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/llfuse')
-rw-r--r--dev-python/llfuse/Manifest2
-rw-r--r--dev-python/llfuse/files/llfuse-1.3-cflags.patch19
-rw-r--r--dev-python/llfuse/llfuse-1.3.2.ebuild43
-rw-r--r--dev-python/llfuse/llfuse-1.3.4.ebuild42
4 files changed, 0 insertions, 106 deletions
diff --git a/dev-python/llfuse/Manifest b/dev-python/llfuse/Manifest
index a61daf4e5e56..cd481d00bcb9 100644
--- a/dev-python/llfuse/Manifest
+++ b/dev-python/llfuse/Manifest
@@ -1,3 +1 @@
-DIST llfuse-1.3.2.tar.bz2 348035 BLAKE2B d3a3219c8d7462f448486488971842362b6ade8fcf6804d725db30b0e91d3f240ec9443705cb67caf3e6beae8a174f323465695dddd132210e3606aef6dd861d SHA512 f065818134b12dd128574836bc7d339404d9b7d9236b535da709378e9206b17cb2accd97fc0b658f39a93efe126a7c3064f7901468231f63f8398a3e053498cf
-DIST llfuse-1.3.4.tar.bz2 364400 BLAKE2B 726a42381b84fc57e3e54d519bc1a105056cc8cf5d1c586ea12b1798db493254df7088f1060ffda0d89887c2b7db2046825e4f044953153e7978891f72032457 SHA512 6bda4534f660c42e6740093be0a2c308367f5915a0144d44c390b4f6b197efafb48bc28f7f8d1735defe470e37637bd6688690e26ec3d0c01cb7c197e443f6e6
DIST llfuse-1.3.5.tar.bz2 362266 BLAKE2B 561439e193470c047aa32b5b4ffd189beca2496b0141d9f0b0d4b494ee135025b174744ac3c90a0e5e8a17cc98f4ab2e8b4a9069f7d73e01a369f5013d036144 SHA512 d45c5fe7e81fd561e016fe99cc7bbac0cf6243e1517e992fe5b302b641aa93c8f95779cb7a4add7a7479f1ed6ca35e0fcf1e4da0fc46ee5d819b46511927613c
diff --git a/dev-python/llfuse/files/llfuse-1.3-cflags.patch b/dev-python/llfuse/files/llfuse-1.3-cflags.patch
deleted file mode 100644
index 42e4eef82a02..000000000000
--- a/dev-python/llfuse/files/llfuse-1.3-cflags.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Build fails under pypy(3) when enabling these flags.
-
---- llfuse-1.3/setup.py
-+++ llfuse-1.3/setup.py
-@@ -84,12 +84,12 @@
- compile_args.append('-Wno-unused-parameter')
-
- # Value-changing conversions should always be explicit.
-- compile_args.append('-Werror=conversion')
-+ # compile_args.append('-Werror=conversion')
-
- # Note that (i > -1) is false if i is unsigned (-1 will be converted to
- # a large positive value). We certainly don't want to do this by
- # accident.
-- compile_args.append('-Werror=sign-compare')
-+ # compile_args.append('-Werror=sign-compare')
-
- # Enable all fatal warnings only when compiling from Mercurial tip.
- # (otherwise we break forward compatibility because compilation with newer
diff --git a/dev-python/llfuse/llfuse-1.3.2.ebuild b/dev-python/llfuse/llfuse-1.3.2.ebuild
deleted file mode 100644
index 800e130cbaa5..000000000000
--- a/dev-python/llfuse/llfuse-1.3.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for the low-level FUSE API"
-HOMEPAGE="https://bitbucket.org/nikratio/python-llfuse/ https://pypi.org/project/llfuse/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=sys-fs/fuse-2.8.0:0
- $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' python2_7 pypy)
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- sys-apps/attr
- virtual/pkgconfig
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-catchlog[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.3-cflags.patch )
-
-python_test() {
- py.test -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/html/. )
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}
diff --git a/dev-python/llfuse/llfuse-1.3.4.ebuild b/dev-python/llfuse/llfuse-1.3.4.ebuild
deleted file mode 100644
index 8d6c4d0e1673..000000000000
--- a/dev-python/llfuse/llfuse-1.3.4.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for the low-level FUSE API"
-HOMEPAGE="https://bitbucket.org/nikratio/python-llfuse/ https://pypi.org/project/llfuse/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=sys-fs/fuse-2.8.0:0
- $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' python2_7 pypy)
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- sys-apps/attr
- virtual/pkgconfig
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.3-cflags.patch )
-
-python_test() {
- py.test -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/html/. )
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}