summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2018-10-02 20:46:12 +0700
committerAndrey Grozin <grozin@gentoo.org>2018-10-02 20:46:12 +0700
commit65b0330bbfb83ff48b70582481db0fa2ae7a3e51 (patch)
tree29c20c638616f859a06f8f9272b78960770de60b /dev-python/mpmath
parentnet-libs/libssh: Fix compile error on HPPA (diff)
downloadgentoo-65b0330bbfb83ff48b70582481db0fa2ae7a3e51.tar.gz
gentoo-65b0330bbfb83ff48b70582481db0fa2ae7a3e51.tar.bz2
gentoo-65b0330bbfb83ff48b70582481db0fa2ae7a3e51.zip
dev-python/mpmath: cleaning old versions
Signed-off-by: Andrey Grozin <grozin@gentoo.org> Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-python/mpmath')
-rw-r--r--dev-python/mpmath/Manifest1
-rw-r--r--dev-python/mpmath/mpmath-0.19-r1.ebuild62
-rw-r--r--dev-python/mpmath/mpmath-0.19-r2.ebuild62
3 files changed, 0 insertions, 125 deletions
diff --git a/dev-python/mpmath/Manifest b/dev-python/mpmath/Manifest
index 0cfa09cfc3de..ff89cb05b2c3 100644
--- a/dev-python/mpmath/Manifest
+++ b/dev-python/mpmath/Manifest
@@ -1,2 +1 @@
DIST mpmath-1.0.0.tar.gz 511349 BLAKE2B 62c6275f76c412043cdafef51815e4b5d055a63ca36f3f63b33957351b19e03419ca27f7d59641c580cf8e47c1ca45240b68b3040e2749b3de679eb45b15a28e SHA512 b225f237008e1cfee52b2f0dca0dce1445b932b6eaef92879d7feca30d728e3f88810bfa80882ad8776ba846a636807e59bebe0b9f690cd878c089e9418bd8b7
-DIST mpmath-all-0.19.tar.gz 2123129 BLAKE2B df7e6255f09362a4203716a5d70036b712d069cc08c09613cabd6d1a88ab5155610f5fe5d2f33db3ed241322e92e93301c54c9cba777c0fbedfb5c891ffa3db0 SHA512 5a6ed0b5fad84c1e8399467ea7a1295f9b77c8e673b821c11e3298e88df6c48d9967eed84e2979bf12868e2f9b42bffba01a0c1836a6d82ac42d5f423fed6580
diff --git a/dev-python/mpmath/mpmath-0.19-r1.ebuild b/dev-python/mpmath/mpmath-0.19-r1.ebuild
deleted file mode 100644
index 85fc57bbf397..000000000000
--- a/dev-python/mpmath/mpmath-0.19-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit distutils-r1 eutils
-
-MY_PN=${PN}-all
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
-HOMEPAGE="http://mpmath.org/"
-SRC_URI="http://mpmath.org/files/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-IUSE="doc examples gmp matplotlib test"
-
-RDEPEND="
- gmp? ( dev-python/gmpy )
- matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}/${PN}.patch"
- )
-
- # this fails with the current version of dev-python/py
- rm ${PN}/conftest.py || die
-
- # this test requires X
- rm ${PN}/tests/test_visualization.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- einfo "Generation of documentation"
- cd doc || die
- "${PYTHON}" build.py || die "Generation of documentation failed"
- fi
-}
-
-python_test() {
- py.test -v || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/. )
- use examples && local EXAMPLES=( demo/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/mpmath/mpmath-0.19-r2.ebuild b/dev-python/mpmath/mpmath-0.19-r2.ebuild
deleted file mode 100644
index 3bd7c37eb1c2..000000000000
--- a/dev-python/mpmath/mpmath-0.19-r2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit distutils-r1 eutils
-
-MY_PN=${PN}-all
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
-HOMEPAGE="http://mpmath.org/"
-SRC_URI="http://mpmath.org/files/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-IUSE="doc examples gmp matplotlib test"
-
-RDEPEND="
- gmp? ( dev-python/gmpy )
- matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}/${PN}.patch"
- )
-
- # this fails with the current version of dev-python/py
- rm ${PN}/conftest.py || die
-
- # this test requires X
- rm ${PN}/tests/test_visualization.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- einfo "Generation of documentation"
- cd doc || die
- "${PYTHON}" build.py || die "Generation of documentation failed"
- fi
-}
-
-python_test() {
- py.test -v || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/. )
- use examples && local EXAMPLES=( demo/. )
- distutils-r1_python_install_all
-}