summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/multipledispatch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/multipledispatch')
-rw-r--r--dev-python/multipledispatch/Manifest3
-rw-r--r--dev-python/multipledispatch/metadata.xml8
-rw-r--r--dev-python/multipledispatch/multipledispatch-0.4.6.ebuild19
-rw-r--r--dev-python/multipledispatch/multipledispatch-0.4.7.ebuild19
-rw-r--r--dev-python/multipledispatch/multipledispatch-0.4.8.ebuild19
5 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/multipledispatch/Manifest b/dev-python/multipledispatch/Manifest
new file mode 100644
index 000000000000..e345fb843c0e
--- /dev/null
+++ b/dev-python/multipledispatch/Manifest
@@ -0,0 +1,3 @@
+DIST multipledispatch-0.4.6.tar.gz 7066 SHA256 9974135f46af8f22096f0517afede26a9b2e015aed9e154c4f5e3173a447162c SHA512 90b7f0ca33abd149ce130124a6464c531698582bb831260266cca1779bf661b6868a3eaff1eab66072e84c464d3bdde517d61b970d6385f33f583fa9bc034d2c WHIRLPOOL 319f1fc7d9a6ea77f2c22a849cd7e5808c21cc792aa5168fdf3adfefe5dea65c17910245db6eb8aefdd74dd72643f3261fb67b9937c47439a897285e462fbeb8
+DIST multipledispatch-0.4.7.tar.gz 7234 SHA256 401bb875cdbd85359f01029e60ef7610bf1172b5052474285daf4102b109496d SHA512 ab1109848560bfbdf66c07d42459729a8e9ee100e4113404447c96e810f52a48bb4aef435e7b4997dfcb1d59959ce491f329c1566f5c4d6c5f6c298a74125d55 WHIRLPOOL 1061fd465f98aee880128cfde7320f5e6c671964382ee24c0b9e296113575296ad833e0e438ff2921795d14f6d2a0d2cc2c893716b4b59394a23445d6e64ee44
+DIST multipledispatch-0.4.8.tar.gz 7393 SHA256 07d41fb3ed25e8424536e48a8566f88a0f9926ca4b6174bff6aa16c98251b92e SHA512 7ca66b4d34a8002babb83678bfc11b1851a23fafea8f59c8240a7c3e8912918439dda236a75c8ae50064e5e87920cf5a7db290a67d6afe1c178010b76c89345d WHIRLPOOL 26263306f29240c052709c2ae5367fd88c936c74e94a478b3474c85c945842d2108d47432e8d855836d9989418cff890a418e51b7c2360899d71bd20cf1b85d5
diff --git a/dev-python/multipledispatch/metadata.xml b/dev-python/multipledispatch/metadata.xml
new file mode 100644
index 000000000000..dcddd9577ad5
--- /dev/null
+++ b/dev-python/multipledispatch/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">multipledispatch</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/multipledispatch/multipledispatch-0.4.6.ebuild b/dev-python/multipledispatch/multipledispatch-0.4.6.ebuild
new file mode 100644
index 000000000000..3d7136cfb978
--- /dev/null
+++ b/dev-python/multipledispatch/multipledispatch-0.4.6.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="RESTful HTTP Content Negotiation for Flask, Bottle, web.py and webapp2"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://pypi.python.org/pypi/mimerender"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/mimeparse[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/multipledispatch/multipledispatch-0.4.7.ebuild b/dev-python/multipledispatch/multipledispatch-0.4.7.ebuild
new file mode 100644
index 000000000000..da58e81ea0a9
--- /dev/null
+++ b/dev-python/multipledispatch/multipledispatch-0.4.7.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="RESTful HTTP Content Negotiation for Flask, Bottle, web.py and webapp2"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://pypi.python.org/pypi/mimerender"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/multipledispatch/multipledispatch-0.4.8.ebuild b/dev-python/multipledispatch/multipledispatch-0.4.8.ebuild
new file mode 100644
index 000000000000..571cadf700f4
--- /dev/null
+++ b/dev-python/multipledispatch/multipledispatch-0.4.8.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="RESTful HTTP Content Negotiation for Flask, Bottle, web.py and webapp2"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://pypi.python.org/pypi/mimerender"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"