summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-10 09:56:58 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-10 09:56:58 +0200
commitc360ebd7cc1d4dd1b14bcba0e8d2fc0a9840dbda (patch)
treeea3ef87320fc1caca62a893ae93e96474c39006b /dev-python/mypy_extensions/mypy_extensions-0.4.3-r1.ebuild
parentdev-python/mypy_extensions: Take for python@ (diff)
downloadgentoo-c360ebd7cc1d4dd1b14bcba0e8d2fc0a9840dbda.tar.gz
gentoo-c360ebd7cc1d4dd1b14bcba0e8d2fc0a9840dbda.tar.bz2
gentoo-c360ebd7cc1d4dd1b14bcba0e8d2fc0a9840dbda.zip
dev-python/mypy_extensions: Modernize the ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mypy_extensions/mypy_extensions-0.4.3-r1.ebuild')
-rw-r--r--dev-python/mypy_extensions/mypy_extensions-0.4.3-r1.ebuild26
1 files changed, 10 insertions, 16 deletions
diff --git a/dev-python/mypy_extensions/mypy_extensions-0.4.3-r1.ebuild b/dev-python/mypy_extensions/mypy_extensions-0.4.3-r1.ebuild
index 472779e6b05f..278bd25dd11f 100644
--- a/dev-python/mypy_extensions/mypy_extensions-0.4.3-r1.ebuild
+++ b/dev-python/mypy_extensions/mypy_extensions-0.4.3-r1.ebuild
@@ -1,31 +1,25 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
DESCRIPTION="Optional static typing for Python"
-HOMEPAGE="http://www.mypy-lang.org/"
-SRC_URI="https://github.com/python/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-if [[ "${PV}" =~ [9]{4,} ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/python/${PN}"
- EGIT_COMMIT="master"
-else
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~x64-macos"
-fi
+HOMEPAGE="
+ http://www.mypy-lang.org/
+ https://github.com/python/mypy_extensions/"
+SRC_URI="
+ https://github.com/python/mypy_extensions/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-
-IUSE="test"
-RESTRICT="!test? ( test )"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~x64-macos"
distutils_enable_tests unittest
python_test() {
- "${PYTHON}" -m unittest discover tests -v || die "tests fail with ${EPYTHON}"
+ eunittest tests
}