summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/numpydoc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/numpydoc')
-rw-r--r--dev-python/numpydoc/Manifest2
-rw-r--r--dev-python/numpydoc/metadata.xml8
-rw-r--r--dev-python/numpydoc/numpydoc-0.4-r1.ebuild34
-rw-r--r--dev-python/numpydoc/numpydoc-0.5.ebuild32
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/numpydoc/Manifest b/dev-python/numpydoc/Manifest
new file mode 100644
index 000000000000..13c1bd5f820b
--- /dev/null
+++ b/dev-python/numpydoc/Manifest
@@ -0,0 +1,2 @@
+DIST numpydoc-0.4.tar.gz 28972 SHA256 20e07c60766a7a044f228de5bdcc0d10b84a9f0b460e0c09422a4f60ef21ff8f SHA512 980c3f56562b0faff4a8f453faff36d8ed92ca7241174c16fe0cc7d60e0d250e6674b6dc2aa98906922f5ccdd0800222b724f759d96174648147ca12e710e574 WHIRLPOOL 8eac57ebcc2eca69b89f98c053332380d902fc1d20dc46bf06768150f14e48b5cf77c203ebf4001766fde05ba9c80ad3bc94ce105ac9e32466c58fc48c64fdad
+DIST numpydoc-0.5.tar.gz 32051 SHA256 93f050bceb52489d92f85c346981f1962c867c01f233d3252894ceae5cb48d34 SHA512 f5ddd07103f3eadad979ddca2bfb4b1681fb783e58de80fbb2cbcb85dcdbe2340f708c94c9d494dce44ac3b1dff1b4b7bcf57231c2eb848f9468b72cec03b038 WHIRLPOOL dbb713f97c0a0a02ae06fd0d2190b2d52471a7ab1c1dcd5bbcf7df98111c97818a32c53c7857648e6c6788818f39b184de6544480382fc011e4a6a52ea43ba1d
diff --git a/dev-python/numpydoc/metadata.xml b/dev-python/numpydoc/metadata.xml
new file mode 100644
index 000000000000..d70636c886e7
--- /dev/null
+++ b/dev-python/numpydoc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">numpydoc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/numpydoc/numpydoc-0.4-r1.ebuild b/dev-python/numpydoc/numpydoc-0.4-r1.ebuild
new file mode 100644
index 000000000000..9679b9d64bac
--- /dev/null
+++ b/dev-python/numpydoc/numpydoc-0.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Sphinx extension to support docstrings in Numpy format"
+HOMEPAGE="https://pypi.python.org/pypi/numpydoc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ chmod -R a+r *.egg-info || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Tests are written only for py2m pypy
+ if ! python_is_python3; then
+ nosetests || die "Testing failed with ${EPYTHON}"
+ fi
+}
diff --git a/dev-python/numpydoc/numpydoc-0.5.ebuild b/dev-python/numpydoc/numpydoc-0.5.ebuild
new file mode 100644
index 000000000000..2859d82c6477
--- /dev/null
+++ b/dev-python/numpydoc/numpydoc-0.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Sphinx extension to support docstrings in Numpy format"
+HOMEPAGE="https://pypi.python.org/pypi/numpydoc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-1.4.0[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ chmod -R a+r *.egg-info || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}