summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Denoncin <ddenoncin@gmail.com>2020-06-14 00:44:25 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-14 09:12:05 +0200
commit8d6a76c0eb3c7e11c8fbd4d3a3880aab31e1dfbc (patch)
treeb6934b2e16f0d9b68c9b812a042737ff1b200f65 /dev-python/ordered-set/ordered-set-4.0.1.ebuild
parentkde-apps: Drop KDE Release Service 20.04.1 (diff)
downloadgentoo-8d6a76c0eb3c7e11c8fbd4d3a3880aab31e1dfbc.tar.gz
gentoo-8d6a76c0eb3c7e11c8fbd4d3a3880aab31e1dfbc.tar.bz2
gentoo-8d6a76c0eb3c7e11c8fbd4d3a3880aab31e1dfbc.zip
dev-python/ordered-set: version bump 4.0.1
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: David Denoncin <ddenoncin@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ordered-set/ordered-set-4.0.1.ebuild')
-rw-r--r--dev-python/ordered-set/ordered-set-4.0.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/ordered-set/ordered-set-4.0.1.ebuild b/dev-python/ordered-set/ordered-set-4.0.1.ebuild
new file mode 100644
index 000000000000..a92064a27062
--- /dev/null
+++ b/dev-python/ordered-set/ordered-set-4.0.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A mutable set that remembers the order of its entries"
+HOMEPAGE="https://github.com/LuminosoInsight/ordered-set"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv test.py || die "Tests fail with ${EPYTHON}"
+}