summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-26 19:29:56 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-26 20:15:20 -0600
commitad7a827eb76c0e56ff9720c4d4719c5b8a374282 (patch)
tree1ed3341a0f975054d7e7cabf2611e91975022036 /dev-python/oslo-cache
parentdev-python/keystonemiddleware: bup (diff)
downloadgentoo-ad7a827eb76c0e56ff9720c4d4719c5b8a374282.tar.gz
gentoo-ad7a827eb76c0e56ff9720c4d4719c5b8a374282.tar.bz2
gentoo-ad7a827eb76c0e56ff9720c4d4719c5b8a374282.zip
dev-python/oslo-cache: bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/oslo-cache')
-rw-r--r--dev-python/oslo-cache/Manifest1
-rw-r--r--dev-python/oslo-cache/oslo-cache-1.17.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/oslo-cache/Manifest b/dev-python/oslo-cache/Manifest
index a2c4f57ae346..10f73ca6c032 100644
--- a/dev-python/oslo-cache/Manifest
+++ b/dev-python/oslo-cache/Manifest
@@ -1,2 +1,3 @@
DIST oslo-cache-1.14.0.tar.gz 45780 SHA256 3ba84b421f80c5a6609789cf17b1da86aab465a96e68298620e839fafec3f0be SHA512 b3638e1cec577bc3779595288ff323baef7b08e534050771ffef80aed9d61e1cb6fc9c034c753768e401f313fba8f7aa0b2f6a3354f272e2498d3972abbcdfd0 WHIRLPOOL 966bde82c0aefe8ea09e8e984ea6c769c983b5ce38d9b4a3b6e4921b66a8b261d81f8dfde4295099234da97bd887c0b00714bf454e634f356d81ba6a574557ca
+DIST oslo-cache-1.17.0.tar.gz 47178 SHA256 bd74257b5bc781112af8862ebd6d41cf58359bc78ccd421cc47f0a79d5337c64 SHA512 0ae55959a46624bd0b50cc8161f9428b3f61669f726ebc05d944f7e049c5172a1d9c83778c9632e8b2a21f047884d90d15b95c0e23a0dd19cb78f8d62f06d00e WHIRLPOOL 28c346d092cf8538a0408e4cd60d48959432090cdbb4bb00ea43524b49dceb84afa786b5456aa71a6938d99c195f940a6741ef3d06e380c5c3fe2607223a5ad0
DIST oslo-cache-1.6.0.tar.gz 36037 SHA256 c357671fb642822924d063b8151e132a6e7a65189c6c35c3f22c64ae0b0bdda8 SHA512 48ea43142d8221a61556ccccbb3c64e8708a1af04514b28dc22049a84d00e14253c9577d05321ef6de62ddc9120789942a82f231f1d7eeca2e5adf2d92ae04d5 WHIRLPOOL 8d06791e971fd6d9e3f49ade330b3c2ad780b162f953a5f9f04d40568efac7b38ae997f53ba315c38af59715d8be95cbab3dd3df051fa1b685b763476bbaf5a6
diff --git a/dev-python/oslo-cache/oslo-cache-1.17.0.ebuild b/dev-python/oslo-cache/oslo-cache-1.17.0.ebuild
new file mode 100644
index 000000000000..0de9648650ef
--- /dev/null
+++ b/dev-python/oslo-cache/oslo-cache-1.17.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Caching around dogpile.cache"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/dogpile-cache-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-3.14.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-3.18.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.11.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}