summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-26 20:47:59 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-26 23:24:32 -0500
commit194e0786805b7d4e2571524d43fb5808fdb7c9dd (patch)
treee9d3797af34bf92c7b6d9351b1a9f3a004030b3a /dev-python/oslo-serialization
parentdev-python/oslo-utils: 3.28.0 bup (diff)
downloadgentoo-194e0786805b7d4e2571524d43fb5808fdb7c9dd.tar.gz
gentoo-194e0786805b7d4e2571524d43fb5808fdb7c9dd.tar.bz2
gentoo-194e0786805b7d4e2571524d43fb5808fdb7c9dd.zip
dev-python/oslo-serialization: 2.20.0 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/oslo-serialization')
-rw-r--r--dev-python/oslo-serialization/Manifest1
-rw-r--r--dev-python/oslo-serialization/oslo-serialization-2.20.0.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/oslo-serialization/Manifest b/dev-python/oslo-serialization/Manifest
index 841d09a90183..1ac7922726c4 100644
--- a/dev-python/oslo-serialization/Manifest
+++ b/dev-python/oslo-serialization/Manifest
@@ -1 +1,2 @@
DIST oslo-serialization-2.16.0.tar.gz 28204 SHA256 0ef8dfa735a42dcfd7d804c5b14576df92407f842d5e12c1fad7eb0889c444fc SHA512 d6612d99e05e3c634d8b2a2e37183884f7aeec3608080bc2bbfcd8e436a64a678e1bb294024ddec0d276fc216fa92a9117a63eb085bc110500e07f1db172e5b0 WHIRLPOOL 5d43524577569a2ee194bc92f387fad10bf15e6922fa315f9559d6a7a6ecba95dfd977f30e7a9086e6120e38fc56f83d37e64f25bc113b6f212f03753f355cbd
+DIST oslo-serialization-2.20.0.tar.gz 28693 SHA256 fca6fbb350d560aab8a4fdc9a1128dac3b1d38b2fc9bf5ad22136ae090854802 SHA512 f15c55a28d1e99b4e01a579f6a3b20d260f8e911ea801b20b27acf3ce284a2bb0ef8a3fa6d6db2d5a094aea9efaa87308b1166ac23dab169209e06bb23d0880c WHIRLPOOL bd2d4fae43f685e2f307c944cce7b9cad21b571ef7bfe7419fba03bc912a2aaa9a1777292a53bcc518663d5b4ac05b3a1e144350d7acefa1657c0a15bad99af5
diff --git a/dev-python/oslo-serialization/oslo-serialization-2.20.0.ebuild b/dev-python/oslo-serialization/oslo-serialization-2.20.0.ebuild
new file mode 100644
index 000000000000..b6311210869e
--- /dev/null
+++ b/dev-python/oslo-serialization/oslo-serialization-2.20.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Serialization library"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ virtual/python-ipaddress[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.13[${PYTHON_USEDEP}]
+ !~dev-python/netaddr-0.7.16[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-i18n-3.15.2[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.11.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ use doc && esetup.py build_sphinx
+ distutils-r1_python_prepare_all
+}
+
+# Note: Tests fail due to requiring installation.
+#
+# Installation appears to fail due ot the use of namespace packages but root
+# cause was never truly established.
+RESTRICT="test"
+
+python_test() {
+ distutils_install_for_testing
+
+ PYTHONPATH="${TEST_DIR}/lib:${PYTHONPATH}"
+
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}