summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-08-10 11:09:40 +0800
committerIan Delaney <idella4@gentoo.org>2015-08-10 11:09:40 +0800
commita11ee91fc0b135a50c9230007d6ca1468eab8a0b (patch)
treeb17251a6cca00b4c8255936fc016641c12943a6c /dev-python/passlib/passlib-1.6.5.ebuild
parentgames-strategy/openra: version bump to 20150424, wrt #547684 (diff)
downloadgentoo-a11ee91fc0b135a50c9230007d6ca1468eab8a0b.tar.gz
gentoo-a11ee91fc0b135a50c9230007d6ca1468eab8a0b.tar.bz2
gentoo-a11ee91fc0b135a50c9230007d6ca1468eab8a0b.zip
bump; update HOMEPAGE, test phase
Package-Manager: portage-2.2.20
Diffstat (limited to 'dev-python/passlib/passlib-1.6.5.ebuild')
-rw-r--r--dev-python/passlib/passlib-1.6.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/passlib/passlib-1.6.5.ebuild b/dev-python/passlib/passlib-1.6.5.ebuild
new file mode 100644
index 000000000000..e69ce65b8d41
--- /dev/null
+++ b/dev-python/passlib/passlib-1.6.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Password hashing framework supporting over 20 schemes"
+HOMEPAGE="https://bitbucket.org/ecollins/passlib/wiki/Home/"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test doc"
+
+RDEPEND="dev-python/bcrypt[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dodoc docs/{*.rst,requirements.txt,lib/*.rst}
+}