summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-06-25 14:43:33 -0400
committerTim Harder <radhermit@gentoo.org>2018-06-25 14:44:47 -0400
commit0766f155395e68eb07ab5670afeef3e33214a924 (patch)
tree1fecedf1692c6f781f14130b315bc637544f757f /dev-python/path-py/path-py-11.0.1.ebuild
parentdev-python/packaging: version bump to 17.1 (diff)
downloadgentoo-0766f155395e68eb07ab5670afeef3e33214a924.tar.gz
gentoo-0766f155395e68eb07ab5670afeef3e33214a924.tar.bz2
gentoo-0766f155395e68eb07ab5670afeef3e33214a924.zip
dev-python/path-py: version bump to 11.0.1
Diffstat (limited to 'dev-python/path-py/path-py-11.0.1.ebuild')
-rw-r--r--dev-python/path-py/path-py-11.0.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/path-py/path-py-11.0.1.ebuild b/dev-python/path-py/path-py-11.0.1.ebuild
new file mode 100644
index 000000000000..730d60b7603b
--- /dev/null
+++ b/dev-python/path-py/path-py-11.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+MY_P="path.py-${PV}"
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="https://pypi.org/project/path.py/ https://github.com/jaraco/path.py"
+SRC_URI="mirror://pypi/p/path.py/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed '/setuptools_scm/d' -i setup.py || die
+
+ # disable flake8 tests
+ sed -i 's/ --flake8//' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH=. py.test -v || die
+}