summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2017-07-15 07:00:35 +0200
committerJohann Schmitz <ercpe@gentoo.org>2017-07-15 08:01:09 +0200
commit529f94f38237e4d4c3bc3d426c719fe05b996e37 (patch)
tree3f34a65e1fe95ca950e16c0579dcd0cb38419965 /dev-python/phonenumbers
parentdev-ruby/shoulda-matchers: add 3.1.2 (diff)
downloadgentoo-529f94f38237e4d4c3bc3d426c719fe05b996e37.tar.gz
gentoo-529f94f38237e4d4c3bc3d426c719fe05b996e37.tar.bz2
gentoo-529f94f38237e4d4c3bc3d426c719fe05b996e37.zip
dev-python/phonenumbers: bump to latest 7.x version to support python 3.5 and 3.6 properly (#620112)
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/phonenumbers')
-rw-r--r--dev-python/phonenumbers/Manifest1
-rw-r--r--dev-python/phonenumbers/phonenumbers-7.7.5.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/phonenumbers/Manifest b/dev-python/phonenumbers/Manifest
index d39f5863f25a..3b61319c057c 100644
--- a/dev-python/phonenumbers/Manifest
+++ b/dev-python/phonenumbers/Manifest
@@ -1,2 +1,3 @@
DIST phonenumbers-7.2.3.tar.gz 4252048 SHA256 7a9735fc1083ddf161e4eb2800cab11abd98b06b4f384c405e4752d654f0aab3 SHA512 73d544c963e4cf33b8cd2d73ba9e4df0c3c77bc2718358ef686a549a5c11d326c4fd73dd11cea97d814732d41021c51e0675d483d133bd44be38eb65ff443689 WHIRLPOOL c455961517ef805f246e8c65ed95a868da9b1c05a20a0d33024cd9435d751c1410dbcde5fbc6520df8ac322785c4339a46db79410e430d61b8ecf852e782c41e
DIST phonenumbers-7.2.8.tar.gz 4255561 SHA256 678a2c6248359206222fe6d6980ec0b1a242767611687dc7fe421c945011d32d SHA512 725d2c446432439f71667afec0b58dff59654c37bcbff1e37b46e0bfe49dc3efd8b23510c2a78b87fbe1c8aba70ad9ca3a9b214423b6aac452429c5065f3c071 WHIRLPOOL 048111bb48ff637eeb5742ff194c3e9de5686233d6ef06275e29d7fa468d7c5ce45c6a8425b51a5f727ff54960f5352791740a7c71863def666d4a5ddc41dace
+DIST phonenumbers-7.7.5.tar.gz 4639483 SHA256 dba4d75250ac66e3cbea3a4d8434db5d0baded6d8a670835622b2d649ce49753 SHA512 af7d573cc2a230a9f2fb06cdc4db0d9f424110fb37382eab2f4f0e91801d910f923f87518c5fc99b400a1e99bf61c516d111ae3dbc71a6bb9c4841a067e6012a WHIRLPOOL 9ff10771e3aad307fda023dbbe1956db0eec6a5b1f3b6116eb84747dbbaefc85db4136d2f05460797b11388c5ce3a74b8cf867541da32e572f316c46728213af
diff --git a/dev-python/phonenumbers/phonenumbers-7.7.5.ebuild b/dev-python/phonenumbers/phonenumbers-7.7.5.ebuild
new file mode 100644
index 000000000000..77ebf1a36080
--- /dev/null
+++ b/dev-python/phonenumbers/phonenumbers-7.7.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python port of Google's libphonenumber"
+HOMEPAGE="https://github.com/daviddrysdale/python-phonenumbers"
+SRC_URI="https://github.com/daviddrysdale/python-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+S="${WORKDIR}/python-${PN}-${PV}"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ # the locale test compiles and runs a .java file
+ sed -i -r 's/^(alldata:.*)locale/\1/g' tools/python/makefile || die
+ emake -C tools/python test
+}