summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/piddle
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/piddle')
-rw-r--r--dev-python/piddle/Manifest1
-rw-r--r--dev-python/piddle/metadata.xml26
-rw-r--r--dev-python/piddle/piddle-1.0.15-r1.ebuild22
-rw-r--r--dev-python/piddle/piddle-1.0.15.ebuild24
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/piddle/Manifest b/dev-python/piddle/Manifest
new file mode 100644
index 000000000000..60bd59ce2029
--- /dev/null
+++ b/dev-python/piddle/Manifest
@@ -0,0 +1 @@
+DIST piddle-1.0.15.tar.gz 454044 SHA256 84c33ba0d054e6b585005aae3a4a99aa5e0d735798fb015c220c24a548d1364d SHA512 5ab216f67721b47360a6e757bddb268173b7fbe3d1a54dfc6dda0a7c050064f833e24911f16882e98af1d56a6ee840a205aa4d0d2e394a375c7abc98d0074a07 WHIRLPOOL e32f4246c8a6eebc155b93ba96c6c5c437c0dd70817513e9e2c0dea43bb3940935d5282969c3a0076dfe9015761978f039e9dd26f8a2294dac051a009735f375
diff --git a/dev-python/piddle/metadata.xml b/dev-python/piddle/metadata.xml
new file mode 100644
index 000000000000..974f176f52ac
--- /dev/null
+++ b/dev-python/piddle/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription>
+PIDDLE is a Python module for creating two-dimensional graphics in a
+manner that is both cross-platform and cross-media; that is, it can
+support screen graphics (e.g. QuickDraw, Windows, Tk) as well as file
+output (PostScript, PDF, GIF, etc.). It makes use of the native 2D
+drawing calls of each backend, for maximum efficiency and quality. It
+works by defining a base class (piddle.Canvas) with methods for all
+supported drawing primitives. A particular drawing context is provided
+in the form of a derived class. PIDDLE applications will be able to
+automatically select an appropriate backend for the user's environment.
+</longdescription>
+ <longdescription lang="ja">
+PIDDLEはクロスプラットフォームとクロスメディアの両方のマナーに沿った二次元画像を
+作成するためのPython言語モジュールです。つまり、これはファイル出力(Postscript, PDF, GIFなど)と同じ様にスクリーン・グラフィック(例えばQuickDraw, TK)をサポートし&gt;ます。最大限の効果と品質のため、ネイティブ2D描画を各バックエンドの呼出しのように
+します。これは原始的なサポートされた描画方法を指すメソッドを持ったベース・クラス
+(Paddle.Canvas)を明確にする事で働きます。特別のドロー・コンテキストは派生元クラ&gt;スのフォームで提供されます。PIDDLEアプリケーションはユーザー環境に適切なバックエ
+ンドを自動的に選択するでしょう。
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">piddle</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/piddle/piddle-1.0.15-r1.ebuild b/dev-python/piddle/piddle-1.0.15-r1.ebuild
new file mode 100644
index 000000000000..e411e656bd30
--- /dev/null
+++ b/dev-python/piddle/piddle-1.0.15-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Cross-media, cross-platform 2D graphics package"
+HOMEPAGE="http://piddle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/piddle/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE="doc"
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/piddle/piddle-1.0.15.ebuild b/dev-python/piddle/piddle-1.0.15.ebuild
new file mode 100644
index 000000000000..31406622425b
--- /dev/null
+++ b/dev-python/piddle/piddle-1.0.15.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Cross-media, cross-platform 2D graphics package"
+HOMEPAGE="http://piddle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/piddle/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ia64 x86"
+IUSE=""
+
+src_install() {
+ distutils_src_install
+ dohtml -r docs/*
+}