summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-19 14:01:41 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-19 14:01:41 +0200
commit06355ea191c5554f2f10543e98445da0af0c60b7 (patch)
tree823c2fabf06f9b7e2d8cbc7ba354c9349ad74c0f /dev-python/pilkit
parentdev-python/django-otp: Require sqlite for tests (diff)
downloadgentoo-06355ea191c5554f2f10543e98445da0af0c60b7.tar.gz
gentoo-06355ea191c5554f2f10543e98445da0af0c60b7.tar.bz2
gentoo-06355ea191c5554f2f10543e98445da0af0c60b7.zip
dev-python/pilkit: Fix pillow USE-dep for tests
Closes: https://bugs.gentoo.org/723600 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pilkit')
-rw-r--r--dev-python/pilkit/pilkit-2.0.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/dev-python/pilkit/pilkit-2.0.ebuild b/dev-python/pilkit/pilkit-2.0.ebuild
index dd16f29d4fb2..6ef202af3c2c 100644
--- a/dev-python/pilkit/pilkit-2.0.ebuild
+++ b/dev-python/pilkit/pilkit-2.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@ -13,17 +13,13 @@ SRC_URI="https://github.com/matthewwithanm/${PN}/archive/${PV}.tar.gz -> ${P}.ta
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-CDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}
+RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+BDEPEND="
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},jpeg,zlib]
)"
-RDEPEND="${CDEPEND}"
-python_test() {
- nosetests --verbose || die
-}
+distutils_enable_tests nose