summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-24 00:34:04 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-24 08:42:56 +0100
commit1098bd2ffc7eed8b18eec40a5732fd047a1c0e3e (patch)
treead3c6c076275a09209800f40f3b1d7dece6a9161 /dev-python/pony
parentdev-python/boto3: Bump to 1.16.24 (diff)
downloadgentoo-1098bd2ffc7eed8b18eec40a5732fd047a1c0e3e.tar.gz
gentoo-1098bd2ffc7eed8b18eec40a5732fd047a1c0e3e.tar.bz2
gentoo-1098bd2ffc7eed8b18eec40a5732fd047a1c0e3e.zip
dev-python/pony: Bump to 0.7.14
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pony')
-rw-r--r--dev-python/pony/Manifest1
-rw-r--r--dev-python/pony/pony-0.7.14.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pony/Manifest b/dev-python/pony/Manifest
index dec2b3288581..0dc616107dc7 100644
--- a/dev-python/pony/Manifest
+++ b/dev-python/pony/Manifest
@@ -1 +1,2 @@
DIST pony-0.7.13.gh.tar.gz 302541 BLAKE2B a1e6f82c6eb72f8626238cbfcc0bc01d1ad3498a75a5ce4c3b8a4511e6d1fbfdd39a239f0462458ae1d64dc9446b338bbaea33d6bbdd861c8d0738e50d58a717 SHA512 431d19e3297ba1cdae5313948123d8b8cd71ee8ad5868b8cc2f5447eb435875fdbcdc3768834b9afe22ce8e4c1abaabeb597f3e6974b00aab33aa61e497d6390
+DIST pony-0.7.14.gh.tar.gz 305795 BLAKE2B a0e056d722a205a00567a230628be6ef8a7fe86f594f91ec0e8bbfc6d6eec17ec1d4cf3f57ad10984b8beb0a90da3010d9a32f2f08dca434af39e20fc6e9126c SHA512 ed27fd697dd14948c282dab6b75e41c9309d0ef4c4cccb0f91e4214e81de52a2de3910e413dfc5495ffcea190a5b50255c45b2beecead84eecb601ba2463d998
diff --git a/dev-python/pony/pony-0.7.14.ebuild b/dev-python/pony/pony-0.7.14.ebuild
new file mode 100644
index 000000000000..6de64d60c256
--- /dev/null
+++ b/dev-python/pony/pony-0.7.14.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python ORM with beautiful query syntax"
+HOMEPAGE="
+ https://ponyorm.org/
+ https://github.com/ponyorm/pony/"
+SRC_URI="
+ https://github.com/ponyorm/pony/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? ( $(python_gen_impl_dep sqlite) )"
+
+distutils_enable_tests unittest