summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-01-09 15:34:24 -0800
committerZac Medico <zmedico@gentoo.org>2018-01-09 17:19:25 -0800
commit33bf6c2c9cc6a3ef75ed1c84cbe2687e19ae7972 (patch)
tree239941f5529c3d7a85bb5379714f5d7bbc0d0118 /dev-python/portend
parentapp-cdr/brasero: replace deprecated gst-plugins-mad dependency with gst-plugi... (diff)
downloadgentoo-33bf6c2c9cc6a3ef75ed1c84cbe2687e19ae7972.tar.gz
gentoo-33bf6c2c9cc6a3ef75ed1c84cbe2687e19ae7972.tar.bz2
gentoo-33bf6c2c9cc6a3ef75ed1c84cbe2687e19ae7972.zip
dev-python/portend: new package
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/portend')
-rw-r--r--dev-python/portend/Manifest1
-rw-r--r--dev-python/portend/metadata.xml12
-rw-r--r--dev-python/portend/portend-2.2.ebuild26
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/portend/Manifest b/dev-python/portend/Manifest
new file mode 100644
index 000000000000..0c788ac69e6e
--- /dev/null
+++ b/dev-python/portend/Manifest
@@ -0,0 +1 @@
+DIST portend-2.2.tar.gz 7974 BLAKE2B 77ffcf02b65f276a5ca1f1bdd76afd54e8f6afcb1c55b6948862017f973772dfe65c9b934ffbc98d2f36f799131d23d4a7128f46e46183010def8936f2dd0bad SHA512 1782132b0dec5b678892190b70ab795b1748dfa17e257b6655fc803f0cf19652725778cd329c3609353f969959501dd11fd2b9726cfcdf2c58689e2ce280c146
diff --git a/dev-python/portend/metadata.xml b/dev-python/portend/metadata.xml
new file mode 100644
index 000000000000..530cb9c31df1
--- /dev/null
+++ b/dev-python/portend/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">portend</remote-id>
+ <remote-id type="github">jaraco/portend</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/portend/portend-2.2.ebuild b/dev-python/portend/portend-2.2.ebuild
new file mode 100644
index 000000000000..4260f3a92b0e
--- /dev/null
+++ b/dev-python/portend/portend-2.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="TCP port monitoring utilities"
+HOMEPAGE="https://pypi.python.org/pypi/portend https://github.com/jaraco/portend"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/tempora-1.8[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v || die "tests failed under ${EPTYHON}"
+}