summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-03-01 02:00:09 -0500
committerTim Harder <radhermit@gentoo.org>2017-03-01 02:01:05 -0500
commit7866bfe152964240139e60f86f7d5576632dc372 (patch)
tree673901db4231a878dae24a07914693d20e401384 /dev-python/py
parentapp-editors/emacs: New release candidate. (diff)
downloadgentoo-7866bfe152964240139e60f86f7d5576632dc372.tar.gz
gentoo-7866bfe152964240139e60f86f7d5576632dc372.tar.bz2
gentoo-7866bfe152964240139e60f86f7d5576632dc372.zip
dev-python/py: version bump to 1.4.32
Diffstat (limited to 'dev-python/py')
-rw-r--r--dev-python/py/Manifest1
-rw-r--r--dev-python/py/py-1.4.32.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/py/Manifest b/dev-python/py/Manifest
index 0fcd0f573b1a..47735d8c4db9 100644
--- a/dev-python/py/Manifest
+++ b/dev-python/py/Manifest
@@ -1,2 +1,3 @@
DIST py-1.4.30.tar.gz 191796 SHA256 b703e57685ed7c280b1a51c496a4984d83d89def2a930b5e9e5da5a6ca151514 SHA512 dd9d92f8eaf8e5fc61bfb7feb4b07df5ae1745ebf88bcbe9d62589caa9e1f7d8beae5b2d20b407520919e47391cd50cf2d5323556fa5bd90a37e120b1d394d7a WHIRLPOOL 890cd2dbb957c291e80c73a69fad89846e761f745500ab2a99bfb4f725a7e567104fa4a2a957b8c674ebc9498fdbb25373ff0d15ab8da7f8c45138844235c79f
DIST py-1.4.31.tar.gz 192212 SHA256 a6501963c725fc2554dabfece8ae9a8fb5e149c0ac0a42fd2b02c5c1c57fc114 SHA512 fd0f4f509d81beb8e5cdb5a8d5d7d40d8a74737c017c915b0630ce740868c32fbf1af4a01dec2ae998e5a9516578e8404ad2b8d966606919767ae25f27eb0b0d WHIRLPOOL 2c1227fc8b3fd044eeea398393a79868b12ef9ab7291522f4c6c08f70d4d725c305a407c3a6893920c405fdf1bc29d97b9ac2a182abdf3a4cde1f6001cd1c38c
+DIST py-1.4.32.tar.gz 598861 SHA256 c4b89fd1ff1162375115608d01f77c38cca1d0f28f37fd718005e19b28be41a7 SHA512 3596d792d8c242c99088001dee1f993f78b1940d8062cb8b81ab3734467a89d30fec790db0baef7fdec23f012b2ec9f70989f09a63cc915e79fb23b1ace47770 WHIRLPOOL ac03859d54effc1642d210f00f30ae26f6d26e0669f6846c219aa56a0079f97ee1df3a2bf7515e36abc215f6f8e59db7caa44e380d1b114ba8686879e21f3891
diff --git a/dev-python/py/py-1.4.32.ebuild b/dev-python/py/py-1.4.32.ebuild
new file mode 100644
index 000000000000..eb54602c31d5
--- /dev/null
+++ b/dev-python/py/py-1.4.32.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="library with cross-python path, ini-parsing, io, code, log facilities"
+HOMEPAGE="http://pylib.readthedocs.org/ https://pypi.python.org/pypi/py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -e 's:intersphinx_mapping:#&:' -i doc/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ # 1 failure, test_comments, under both pypy only.
+ # Also appears the home repo has no issue tracker.
+ [[ "${EPYTHON}" == pypy ]] && return
+ py.test -v -v || die "testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}