summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-27 04:30:38 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-27 04:34:35 -0400
commitc797bce25bbe3e081ab38d803dc62d01581a566d (patch)
tree42dc1788262a1a56c273d78bd55d0e360fed10a1 /dev-python/py
parentdev-python/decorator: use consistent indentation for metadata (diff)
downloadgentoo-c797bce25bbe3e081ab38d803dc62d01581a566d.tar.gz
gentoo-c797bce25bbe3e081ab38d803dc62d01581a566d.tar.bz2
gentoo-c797bce25bbe3e081ab38d803dc62d01581a566d.zip
dev-python/py: version bump to 1.4.34
Diffstat (limited to 'dev-python/py')
-rw-r--r--dev-python/py/Manifest1
-rw-r--r--dev-python/py/py-1.4.34.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/py/Manifest b/dev-python/py/Manifest
index f1ae8ce5a6b9..4c09a5ca3829 100644
--- a/dev-python/py/Manifest
+++ b/dev-python/py/Manifest
@@ -1,3 +1,4 @@
DIST py-1.4.30.tar.gz 191796 SHA256 b703e57685ed7c280b1a51c496a4984d83d89def2a930b5e9e5da5a6ca151514 SHA512 dd9d92f8eaf8e5fc61bfb7feb4b07df5ae1745ebf88bcbe9d62589caa9e1f7d8beae5b2d20b407520919e47391cd50cf2d5323556fa5bd90a37e120b1d394d7a WHIRLPOOL 890cd2dbb957c291e80c73a69fad89846e761f745500ab2a99bfb4f725a7e567104fa4a2a957b8c674ebc9498fdbb25373ff0d15ab8da7f8c45138844235c79f
DIST py-1.4.32.tar.gz 598861 SHA256 c4b89fd1ff1162375115608d01f77c38cca1d0f28f37fd718005e19b28be41a7 SHA512 3596d792d8c242c99088001dee1f993f78b1940d8062cb8b81ab3734467a89d30fec790db0baef7fdec23f012b2ec9f70989f09a63cc915e79fb23b1ace47770 WHIRLPOOL ac03859d54effc1642d210f00f30ae26f6d26e0669f6846c219aa56a0079f97ee1df3a2bf7515e36abc215f6f8e59db7caa44e380d1b114ba8686879e21f3891
DIST py-1.4.33.tar.gz 193961 SHA256 1f9a981438f2acc20470b301a07a496375641f902320f70e31916fe3377385a9 SHA512 5474ba113b205e499acae78a1bfedcdcea5eb61c35aa17bce73e6a49d316ca2dc9e19c4d17e1dd084424ef9f50b5a4ba045b1bb7a8bd7a6d7062afa552354cb6 WHIRLPOOL b5b67c7c2f925ea966e6be0c1016e3752d4239446274c6af92bd03a8d11400856ecdd57818f70b3257a910964a1ee53597a022f2ea9862b8dd55a8c9b7c1ae9b
+DIST py-1.4.34.tar.gz 194450 SHA256 0f2d585d22050e90c7d293b6451c83db097df77871974d90efd5a30dc12fcde3 SHA512 2e19c82c8315274bffe0ba2c7e20ae3af95f942c40c16121ec953af186f8ff33e8f427c070e137bb04b7cc6dcc6779e35df3911c08595fd3294b5ec9897706e1 WHIRLPOOL 7e7c4b3eb9697af183e4b6c78cea11a2f75e1cfa00f02d80df1ead777baf1e826577175ce06993a1918ede00103249d501594b5245d9b1560501df55e897f835
diff --git a/dev-python/py/py-1.4.34.ebuild b/dev-python/py/py-1.4.34.ebuild
new file mode 100644
index 000000000000..eb54602c31d5
--- /dev/null
+++ b/dev-python/py/py-1.4.34.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="library with cross-python path, ini-parsing, io, code, log facilities"
+HOMEPAGE="http://pylib.readthedocs.org/ https://pypi.python.org/pypi/py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -e 's:intersphinx_mapping:#&:' -i doc/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ # 1 failure, test_comments, under both pypy only.
+ # Also appears the home repo has no issue tracker.
+ [[ "${EPYTHON}" == pypy ]] && return
+ py.test -v -v || die "testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}