summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiogo Pereira <sir.suriv@gmail.com>2020-10-03 14:51:32 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-10-10 10:22:36 +0300
commit3399658765ae0d7a09afbdac7e2ca78b45658852 (patch)
tree47ff8ab06d85f85cd115b41dc6ff598b95393f05 /dev-python/pyacoustid
parentmedia-gfx/xfig: update SRC_URI for 3.2.7b (diff)
downloadgentoo-3399658765ae0d7a09afbdac7e2ca78b45658852.tar.gz
gentoo-3399658765ae0d7a09afbdac7e2ca78b45658852.tar.bz2
gentoo-3399658765ae0d7a09afbdac7e2ca78b45658852.zip
dev-python/pyacoustid: version bump to 1.2.0
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Diogo Pereira <sir.suriv@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17760 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/pyacoustid')
-rw-r--r--dev-python/pyacoustid/Manifest1
-rw-r--r--dev-python/pyacoustid/pyacoustid-1.2.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pyacoustid/Manifest b/dev-python/pyacoustid/Manifest
index 4ad37cc0f196..54807430a2c0 100644
--- a/dev-python/pyacoustid/Manifest
+++ b/dev-python/pyacoustid/Manifest
@@ -1 +1,2 @@
DIST pyacoustid-1.1.7.tar.gz 14990 BLAKE2B 866fa4a03032f15daa2b8dd06119eb6edc777dec4bc673fe2564363f85906bbe451b2ca16e6911e143e7172c728f1a700f5fc426f9a4de9786c1429e475379cc SHA512 2bd301ce51df8a352c71493dac5b5c15cdd0af0a9a0bf0c8640857a9d99c5f0c9d59c5c2bf8c2aec61689481dacc42948f847e0c11ac7d581a7338e6d1088162
+DIST pyacoustid-1.2.0.tar.gz 15770 BLAKE2B 9a5d62a8b8450393aec103d3755ed9e1fa999b6d4b25d1180d12e96020bb8bcf44b32f7de2e7de2ab0902ca9e65b352bc09edca173ce738019f4ca3330489875 SHA512 45827841df97b0f3a5d090edb076456fb822dfb35f3efbe55cc2877801b6c706f22a38f216d4ce7e4217d7da650e2116cfd987ea87000c828b06221fb8b06312
diff --git a/dev-python/pyacoustid/pyacoustid-1.2.0.ebuild b/dev-python/pyacoustid/pyacoustid-1.2.0.ebuild
new file mode 100644
index 000000000000..22f63e1faf79
--- /dev/null
+++ b/dev-python/pyacoustid/pyacoustid-1.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Chromaprint and the AcoustID web service"
+HOMEPAGE="https://pypi.org/project/pyacoustid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/audioread[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ media-libs/chromaprint
+"
+
+src_install() {
+ distutils-r1_src_install
+
+ if use examples ; then
+ docinto examples
+ dodoc aidmatch.py fpcalc.py
+ docompress -x /usr/share/doc/${PF}/examples/
+ fi
+}