summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-29 09:24:11 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-29 09:28:17 +0200
commit56e5ebb02a0d25a74bf7d1db13c1b7157d9b7b95 (patch)
tree22c1a6c73f02997207ff79ab14cf535a1e9ecdd9 /dev-python/pyasn1
parentdev-python/kiwisolver: Remove world write permission from files (diff)
downloadgentoo-56e5ebb02a0d25a74bf7d1db13c1b7157d9b7b95.tar.gz
gentoo-56e5ebb02a0d25a74bf7d1db13c1b7157d9b7b95.tar.bz2
gentoo-56e5ebb02a0d25a74bf7d1db13c1b7157d9b7b95.zip
dev-python/pyasn1: Version Bump
Package-Manager: portage-2.2.22 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pyasn1')
-rw-r--r--dev-python/pyasn1/Manifest1
-rw-r--r--dev-python/pyasn1/pyasn1-0.1.9.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pyasn1/Manifest b/dev-python/pyasn1/Manifest
index 34c72dce1b81..9e42c8408042 100644
--- a/dev-python/pyasn1/Manifest
+++ b/dev-python/pyasn1/Manifest
@@ -1,2 +1,3 @@
DIST pyasn1-0.1.7.tar.gz 68120 SHA256 e4f81d53c533f6bd9526b047f047f7b101c24ab17339c1a7ad8f98b25c101eab SHA512 af2ac05fb7e18b25bd125f92bd7c8389a00c18018c1ff48d94c196f5ab41b09c8991d2e326d492cfaed755b06cd4c75d88719b4a390bdab6d84fe3c8791620af WHIRLPOOL 902b80616cecbf3549417c95ec09c060c6a038f95bd71ce2f9a5c0cd1e4cfd4e9157252abedec3002588eaba5a3cecd7100138c952a5e8f8b7e245b4f82d5c7c
DIST pyasn1-0.1.8.tar.gz 75676 SHA256 5d33be7ca0ec5997d76d29ea4c33b65c00c0231407fff975199d7f40530b8347 SHA512 0a0b9b8018ae80a0e0d84ea3a4f217951bf42dce909a354c97890d4b4fc4f49b19d9d0757103ac9002c17c6c622c8e8d66e1f8242b8545a7da455ef3583acdfa WHIRLPOOL db46e06ef9a6b5858c07f1c154657f998b509c457395b4f2e6286ea90e1b16346e24d92a8d666b5db4216e35129f2d6be13c2fc11aae2d9936163bff3b1400eb
+DIST pyasn1-0.1.9.tar.gz 75947 SHA256 853cacd96d1f701ddd67aa03ecc05f51890135b7262e922710112f12a2ed2a7f SHA512 c72bdba84c4cc860a1790d752861dc9de30dabb61e5146a551597b4a97e64797dbd6e575e61cb9a8b23ffc58bced143b0ed55a7c98d0a85834ccd60b17856df5 WHIRLPOOL 2d47a9cf1a04a9f07a053926bd4d317ae71f52e7df88b9be53ff343d1e82770cb5c6709e6fa154e9cf0bb05e47c6c24f6736899bbf41c39a01f6d0211cfb98a5
diff --git a/dev-python/pyasn1/pyasn1-0.1.9.ebuild b/dev-python/pyasn1/pyasn1-0.1.9.ebuild
new file mode 100644
index 000000000000..a01b4fdad97a
--- /dev/null
+++ b/dev-python/pyasn1/pyasn1-0.1.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ASN.1 library for Python"
+HOMEPAGE="http://pyasn1.sourceforge.net/ https://pypi.python.org/pypi/pyasn1"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" test/suite.py || die "Tests fail with ${EPYTHON}"
+}
+
+src_install() {
+ local HTML_DOCS=( doc/pyasn1-tutorial.html )
+ use doc && HTML_DOCS=( doc/. )
+
+ distutils-r1_src_install
+}