summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-03-11 20:36:02 +0200
committerMart Raudsepp <leio@gentoo.org>2019-03-11 20:36:02 +0200
commit0945241c04c71df904276a671da9783dbd4aa698 (patch)
tree2aa3ddbc2334aa1760cd7990ec3247c23d4bfb83 /dev-python/pyatspi
parentapp-arch/gnome-autoar: bump to 0.2.3 (diff)
downloadgentoo-0945241c04c71df904276a671da9783dbd4aa698.tar.gz
gentoo-0945241c04c71df904276a671da9783dbd4aa698.tar.bz2
gentoo-0945241c04c71df904276a671da9783dbd4aa698.zip
dev-python/pyatspi: bump to 2.30.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-python/pyatspi')
-rw-r--r--dev-python/pyatspi/Manifest1
-rw-r--r--dev-python/pyatspi/pyatspi-2.30.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/pyatspi/Manifest b/dev-python/pyatspi/Manifest
index 3c438ea0bad3..50d269886f5b 100644
--- a/dev-python/pyatspi/Manifest
+++ b/dev-python/pyatspi/Manifest
@@ -1,2 +1,3 @@
DIST pyatspi-2.24.0.tar.xz 298228 BLAKE2B a1c989df5431a9fdf0b35c5fa75a12b9c083c6a979052e3a621685feada611f4322195b30bc1f4f56cd35f305087756cded31a445cca07e74262ecd807926239 SHA512 ea0c3e5a5a417c4d494cfe33ccfcca1996f417e51f5ccd3508372a0df636fb186b9940d7832681af9b353aa50a9aabd64c5477fdabbc5016794a502396b3d67a
DIST pyatspi-2.26.0.tar.xz 309780 BLAKE2B f3657052ef7c5fde35506e04e5f1a3920fed5edd1af182b3e9bff6fc0461595e9b14644c8858d6f12b1042d57231fc09ae5061129d74a1030e0c8de88364ec7b SHA512 a1aa7e608fa95bdf4c891666fe5038dd2fd7cc7e675cef4c9759ffed4f6342e3cebbc6d5fad8899c0c91eda29664a5f8ff06a1cb0ab46958c8f629cd014d3579
+DIST pyatspi-2.30.0.tar.xz 310672 BLAKE2B 76d51e6ce2f39305bcda8f706b5207738d3a2c0fd7480efb77c4dab8baf8ed6eb71263375ff0c16be0087e47f7f6b5eab99c6fc8992b83bdea6e64c92c381043 SHA512 a7af81bb55dff45d1bceced645f6aeb1adc1fa2a2b61fc39d9e97b6659e474636e5ac1af9923588311e651fee57b5e31a62ea5b2977b341eda43a5a736bf27ed
diff --git a/dev-python/pyatspi/pyatspi-2.30.0.ebuild b/dev-python/pyatspi/pyatspi-2.30.0.ebuild
new file mode 100644
index 000000000000..25898e111ef4
--- /dev/null
+++ b/dev-python/pyatspi/pyatspi-2.30.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Python binding to at-spi library"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+# Note: only some of the tests are GPL-licensed, everything else is LGPL
+LICENSE="LGPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="" # test
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-libs/atk-2.11.2
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.90.1:3[${PYTHON_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/dbus-1
+ >=app-accessibility/at-spi2-core-2.20.2[introspection]
+ !<gnome-extra/at-spi-1.32.0-r1
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # https://bugzilla.gnome.org/show_bug.cgi?id=689957
+ "${FILESDIR}/${PN}-2.6.0-examples-python3.patch"
+)
+
+src_prepare() {
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure --disable-tests
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir gnome2_src_install
+
+ docinto examples
+ dodoc examples/*.py
+}