summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-11-23 23:04:49 -0500
committerMike Gilbert <floppym@gentoo.org>2016-11-23 23:04:49 -0500
commitea604c2871dd4b3e6f902f6fa27ffe534e01236d (patch)
treef67a6858e9df4dc4c64e0cb797f0370294c0c56b /dev-python/pybluez/pybluez-0.22.ebuild
parentdev-python/progressbar: drop googlecode upstream element (diff)
downloadgentoo-ea604c2871dd4b3e6f902f6fa27ffe534e01236d.tar.gz
gentoo-ea604c2871dd4b3e6f902f6fa27ffe534e01236d.tar.bz2
gentoo-ea604c2871dd4b3e6f902f6fa27ffe534e01236d.zip
dev-python/pybluez: bump to 0.22
Package-Manager: portage-2.3.2_p8
Diffstat (limited to 'dev-python/pybluez/pybluez-0.22.ebuild')
-rw-r--r--dev-python/pybluez/pybluez-0.22.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pybluez/pybluez-0.22.ebuild b/dev-python/pybluez/pybluez-0.22.ebuild
new file mode 100644
index 000000000000..da677618289d
--- /dev/null
+++ b/dev-python/pybluez/pybluez-0.22.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+MY_P="PyBluez-${PV}"
+
+DESCRIPTION="Python bindings for Bluez Bluetooth Stack"
+HOMEPAGE="https://github.com/karulis/pybluez"
+SRC_URI="mirror://pypi/P/PyBluez/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+RDEPEND="net-wireless/bluez"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x usr/share/doc/${PF}/examples
+ fi
+}