summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-09-20 10:05:23 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-20 10:43:08 +0200
commit96617c430559d99482be2146d3705b8583d7d710 (patch)
tree7ec73608afcaa5991abcb3faada1ac19fd8166e8 /dev-python/pycountry
parentdev-python/recommonmark: Bump to 0.5.0_pre20180907 (diff)
downloadgentoo-96617c430559d99482be2146d3705b8583d7d710.tar.gz
gentoo-96617c430559d99482be2146d3705b8583d7d710.tar.bz2
gentoo-96617c430559d99482be2146d3705b8583d7d710.zip
dev-python/pycountry: Bump to 8.5.26
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycountry')
-rw-r--r--dev-python/pycountry/Manifest1
-rw-r--r--dev-python/pycountry/pycountry-18.5.26.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pycountry/Manifest b/dev-python/pycountry/Manifest
index a00882f9110e..12c2615a330d 100644
--- a/dev-python/pycountry/Manifest
+++ b/dev-python/pycountry/Manifest
@@ -1,2 +1,3 @@
DIST pycountry-16.11.8.tar.gz 9042735 BLAKE2B 66f5dcb0b9b55be692e398c998babeb49542cb5383a706bb74091088eaa3703f41da33f59e2267046c53f8f025f85945096d1e8d251ad5af57c5d39a27896cf2 SHA512 eb0a91f1efae6aeace0b49cd44b0770efa0b57add208c4247e7f58a3c46774f9f8007c51ee88a0e108c90ced3ad69204b4322c9c23f51df0b2202aa98c314a37
DIST pycountry-17.9.23.tar.gz 9208478 BLAKE2B 381497b220991f76bdac235b71fd9c10984f5762e9cc16b813cb37cfef0444bbaada01e1ed9513848c681a06335ff58544f6f7c2217b51ef98c7415db4b3d285 SHA512 168e2d2693629a39a85a4c6aa7187323693ca73d6af0cc947d3536ae373eca602e7e3add91ba114966db4ebf52118ef3d6a3dbf8339734ec68682bab559beeb5
+DIST pycountry-18.5.26.tar.gz 9779056 BLAKE2B 11928f29cb7446db7159936619a5d0828af89ec7a2ca355d809c97887605174e41d3f93d7e459f3f37ce37b9a7650432df1e7619f9fdfa1f9ea010a39af4501a SHA512 9760175a7926347920542a2fd2420cc3d4f36ac11df5aa6f7aaabbd9b46dd9cb61801933133a589ed35fd2e279db2a70e98340d8cf8856987dc88d6fdb715437
diff --git a/dev-python/pycountry/pycountry-18.5.26.ebuild b/dev-python/pycountry/pycountry-18.5.26.ebuild
new file mode 100644
index 000000000000..4ceff4ecf3ee
--- /dev/null
+++ b/dev-python/pycountry/pycountry-18.5.26.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Database of countries, subdivisions, languages, currencies and script"
+HOMEPAGE="https://bitbucket.org/flyingcircus/pycountry"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ # https://bitbucket.org/techtonik/pycountry/issue/8/test_locales-pycountry-015-pypy
+ pushd "${BUILD_DIR}"/lib > /dev/null || die
+ if [[ ${EPYTHON} == pypy* ]]; then
+ sed -e 's:test_locales:_&:' -i pycountry/tests/test_general.py || die
+ fi
+ pytest -vv || die
+ popd > /dev/null || die
+}