summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pydb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pydb')
-rw-r--r--dev-python/pydb/Manifest1
-rw-r--r--dev-python/pydb/metadata.xml13
-rw-r--r--dev-python/pydb/pydb-1.26-r1.ebuild56
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/pydb/Manifest b/dev-python/pydb/Manifest
new file mode 100644
index 000000000000..d9fad97a4fb9
--- /dev/null
+++ b/dev-python/pydb/Manifest
@@ -0,0 +1 @@
+DIST pydb-1.26.tar.bz2 572184 SHA256 01131848a58fce6a529766488884848c06068aa9ec4f39e19f8fb4d260f893f2 SHA512 39365ddcd863404079e4a7159bbbedbfa6a99b3d46e95c07fe14be61a2805b9237df5e51a8a68db159fca2df4b0bd46bddaebbe610d1597064f2df4e64393355 WHIRLPOOL 26a887e19dc157c612d4c4fa07fa1d4e0be0e051e23f680ed1b3368c4b12ad353d631893b81bfa8bbd48358d5ff4383de18876deffa467af2762d49f39cb833e
diff --git a/dev-python/pydb/metadata.xml b/dev-python/pydb/metadata.xml
new file mode 100644
index 000000000000..bfa2bf74f9b0
--- /dev/null
+++ b/dev-python/pydb/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription>Extended python debugger</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">bashdb</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pydb/pydb-1.26-r1.ebuild b/dev-python/pydb/pydb-1.26-r1.ebuild
new file mode 100644
index 000000000000..c17011eda1b3
--- /dev/null
+++ b/dev-python/pydb/pydb-1.26-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+
+inherit elisp-common python
+
+DESCRIPTION="Extended python debugger"
+HOMEPAGE="http://bashdb.sourceforge.net/pydb/"
+SRC_URI="mirror://sourceforge/bashdb/${P}.tar.bz2"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs"
+
+DEPEND="
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ echo "#!/bin/sh" > py-compile
+
+ # Fix pydb symlinks.
+ sed -e '/$(LN_S) "$(DESTDIR)$(pkgpythondir)\/$(python_debugger_script)" "$(DESTDIR)$(bindir)\/$(bin_SCRIPTS)"/s/$(DESTDIR)$(pkgpythondir)/$(pkgpythondir)/' -i Makefile.in
+
+ python_src_prepare
+}
+
+src_configure() {
+ configuration() {
+ econf --with-lispdir="${SITELISP}/${PN}" \
+ EMACS="$(use emacs && echo "${EMACS}" || echo no)" \
+ --with-site-packages=$(python_get_sitedir) \
+ --with-python=$(PYTHON -a)
+ }
+ python_execute_function -s configuration
+}
+
+src_install() {
+ python_src_install
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}
+
+pkg_postinst() {
+ python_mod_optimize pydb
+}
+
+pkg_postrm() {
+ python_mod_cleanup pydb
+}