summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pygpgme
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pygpgme')
-rw-r--r--dev-python/pygpgme/Manifest1
-rw-r--r--dev-python/pygpgme/metadata.xml18
-rw-r--r--dev-python/pygpgme/pygpgme-0.3-r1.ebuild33
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pygpgme/Manifest b/dev-python/pygpgme/Manifest
new file mode 100644
index 000000000000..51674038fade
--- /dev/null
+++ b/dev-python/pygpgme/Manifest
@@ -0,0 +1 @@
+DIST pygpgme-0.3.tar.gz 50100 SHA256 5fd887c407015296a8fd3f4b867fe0fcca3179de97ccde90449853a3dfb802e1 SHA512 25fc199a7958adfa3bbb294108792974ba96ee7b15dff98f7933e9b089a6044d83bb7c7b77ca84ea0cab5b182f6d401cee42ecab57ab9ba34aa0b14eb6ce7736 WHIRLPOOL 58657f106702a402f466415301530e56cd7287592da012b8869b5bb0a985b0560be4fb12699c22b1949d6ea2f18a6eed943b5e8af59f80855eace82ef4d21017
diff --git a/dev-python/pygpgme/metadata.xml b/dev-python/pygpgme/metadata.xml
new file mode 100644
index 000000000000..cc608635cc22
--- /dev/null
+++ b/dev-python/pygpgme/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>aidecoe@gentoo.org</email>
+ <name>Amadeusz Żołnowski</name>
+ </maintainer>
+ <longdescription lang="en">
+ PyGPGME is a Python module that lets you sign, verify, encrypt and
+ decrypt messages using the OpenPGP format. It is built on top of the
+ GNU Privacy Guard and the GPGME
+ library.
+ </longdescription>
+ <upstream>
+ <remote-id type="launchpad">pygpgme</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pygpgme/pygpgme-0.3-r1.ebuild b/dev-python/pygpgme/pygpgme-0.3-r1.ebuild
new file mode 100644
index 000000000000..8510bb2e4865
--- /dev/null
+++ b/dev-python/pygpgme/pygpgme-0.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python wrapper for the GPGME library"
+HOMEPAGE="https://launchpad.net/pygpgme"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-crypt/gpgme"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ sed \
+ -e 's/#include <gpgme\.h>/#include <gpgme\/gpgme\.h>/' \
+ -i "${S}/src/pygpgme.h" || die
+ sed \
+ -e 's/suite.addTest(tests.test_sign_verify.test_suite())/#\0/' \
+ -e 's/suite.addTest(tests.test_encrypt_decrypt.test_suite())/#\0/' \
+ -e 's/suite.addTest(tests.test_passphrase.test_suite())/#\0/' \
+ -i "${S}/tests/__init__.py" || die
+ distutils-r1_python_prepare_all
+}