summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-05 10:05:48 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-05 10:17:09 +0100
commit62526354aa38cc725034b0cae98bccce8e23365e (patch)
tree29949672c760e6a42cae61205b3edf7934e8e155 /dev-python/pylast/pylast-4.1.0.ebuild
parentdev-python/pytest-mock: Bump to 3.5.0 (diff)
downloadgentoo-62526354aa38cc725034b0cae98bccce8e23365e.tar.gz
gentoo-62526354aa38cc725034b0cae98bccce8e23365e.tar.bz2
gentoo-62526354aa38cc725034b0cae98bccce8e23365e.zip
dev-python/pylast: Bump to 4.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylast/pylast-4.1.0.ebuild')
-rw-r--r--dev-python/pylast/pylast-4.1.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pylast/pylast-4.1.0.ebuild b/dev-python/pylast/pylast-4.1.0.ebuild
new file mode 100644
index 000000000000..bdb88af44809
--- /dev/null
+++ b/dev-python/pylast/pylast-4.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="https://github.com/pylast/pylast"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/flaky[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "tests failed with ${EPYTHON}"
+}