summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-25 23:29:11 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-25 23:30:45 +0300
commitfe95e4b9959c57fd5cdd7ee51e8628c22a19a83f (patch)
treec25b7a27300afa7c93798ce923ddf94bb5ff10c0 /dev-python/pylast/pylast-5.1.0.ebuild
parentdev-python/cfn-lint: add 0.69.0 (diff)
downloadgentoo-fe95e4b9959c57fd5cdd7ee51e8628c22a19a83f.tar.gz
gentoo-fe95e4b9959c57fd5cdd7ee51e8628c22a19a83f.tar.bz2
gentoo-fe95e4b9959c57fd5cdd7ee51e8628c22a19a83f.zip
dev-python/pylast: add 5.1.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pylast/pylast-5.1.0.ebuild')
-rw-r--r--dev-python/pylast/pylast-5.1.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pylast/pylast-5.1.0.ebuild b/dev-python/pylast/pylast-5.1.0.ebuild
new file mode 100644
index 000000000000..07ac0a967207
--- /dev/null
+++ b/dev-python/pylast/pylast-5.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="
+ https://pypi.org/project/pylast/
+ https://github.com/pylast/pylast/
+"
+SRC_URI="
+ https://github.com/pylast/pylast/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/httpx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}