summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-17 22:27:18 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-17 22:33:39 +0200
commit5ee6d2db3ae368f4d2d5e605af12892df8a451d8 (patch)
tree4c94b6620a6a3b80d2c81cbd575c7f4b153c39fc /dev-python/pylibacl/pylibacl-0.5.4_p20191217.ebuild
parentprofiles/profiles.desc: revert "deprecate most ia64 profiles" (diff)
downloadgentoo-5ee6d2db3ae368f4d2d5e605af12892df8a451d8.tar.gz
gentoo-5ee6d2db3ae368f4d2d5e605af12892df8a451d8.tar.bz2
gentoo-5ee6d2db3ae368f4d2d5e605af12892df8a451d8.zip
dev-python/pylibacl: Bump to 0.5.4_p20191217 snap
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylibacl/pylibacl-0.5.4_p20191217.ebuild')
-rw-r--r--dev-python/pylibacl/pylibacl-0.5.4_p20191217.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pylibacl/pylibacl-0.5.4_p20191217.ebuild b/dev-python/pylibacl/pylibacl-0.5.4_p20191217.ebuild
new file mode 100644
index 000000000000..bad633dc47b9
--- /dev/null
+++ b/dev-python/pylibacl/pylibacl-0.5.4_p20191217.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+EGIT_COMMIT=2ae494bd2e3303141a703f32e44263e083c1ffb0
+DESCRIPTION="POSIX ACLs (Access Control Lists) for Python"
+HOMEPAGE="
+ https://pylibacl.k1024.org/
+ https://pypi.org/project/pylibacl/
+ https://github.com/iustin/pylibacl/"
+SRC_URI="
+ https://github.com/iustin/pylibacl/archive/${EGIT_COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="sys-apps/acl"
+DEPEND=${RDEPEND}
+
+distutils_enable_tests pytest
+
+python_test() {
+ if ! pytest -vv; then
+ eerror
+ eerror "If you got the following errors:"
+ eerror "\"IOError: [Errno 95] Operation not supported\","
+ eerror "then you should remount the filesystem containing"
+ eerror "build directory with \"acl\" option enabled."
+ eerror
+ die "Tests fail with ${EPYTHON}"
+ fi
+}