summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyliblzma
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyliblzma')
-rw-r--r--dev-python/pyliblzma/Manifest1
-rw-r--r--dev-python/pyliblzma/metadata.xml9
-rw-r--r--dev-python/pyliblzma/pyliblzma-0.5.3-r1.ebuild28
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyliblzma/Manifest b/dev-python/pyliblzma/Manifest
new file mode 100644
index 000000000000..7fb21c85e519
--- /dev/null
+++ b/dev-python/pyliblzma/Manifest
@@ -0,0 +1 @@
+DIST pyliblzma-0.5.3.tar.bz2 43498 SHA256 08d762f36d5e59fb9bb0e22e000c300b21f97e35b713321ee504cfb442667957 SHA512 272983aac426e86d6d636ccba4fe78a07d7282560081df937114162bfd317bd8023814693b8d473d0f7884e38a968ebeaf8f954a5a27c1f7e5da084f3fd05c65 WHIRLPOOL 289fc18a8cf7b90f53f06bd4cc3865b4e02f87710bf0ade15c11d2774f86ff826171483f746765cda67628ae3d78f7914448e652a6b5e69c0c572d357e3cac20
diff --git a/dev-python/pyliblzma/metadata.xml b/dev-python/pyliblzma/metadata.xml
new file mode 100644
index 000000000000..ea2a8b112c95
--- /dev/null
+++ b/dev-python/pyliblzma/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">pyliblzma</remote-id>
+ <remote-id type="launchpad">pyliblzma</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyliblzma/pyliblzma-0.5.3-r1.ebuild b/dev-python/pyliblzma/pyliblzma-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..c80d52a831af
--- /dev/null
+++ b/dev-python/pyliblzma/pyliblzma-0.5.3-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for liblzma"
+HOMEPAGE="https://launchpad.net/pyliblzma http://pypi.python.org/pypi/pyliblzma"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="app-arch/xz-utils"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig"
+
+DOCS="THANKS"
+
+python_test() {
+ esetup.py test
+}