summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pymtp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pymtp')
-rw-r--r--dev-python/pymtp/Manifest1
-rw-r--r--dev-python/pymtp/metadata.xml6
-rw-r--r--dev-python/pymtp/pymtp-0.0.6.ebuild29
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pymtp/Manifest b/dev-python/pymtp/Manifest
new file mode 100644
index 000000000000..e39824cdc80a
--- /dev/null
+++ b/dev-python/pymtp/Manifest
@@ -0,0 +1 @@
+DIST pymtp_0.0.6.orig.tar.gz 22431 SHA256 c729beddad8d200afeefd0bf59b01065b9fe276a3845a4a4940eca4ea2e3a47b SHA512 f50249c6b2acfe2c86da5e5f8a24e1392d47e0ddd02d10891763a3150f9985ecdb8a0b7c7ce8bc36f53f2bf62073a26dd3a72b6c3f95d59cd447bb55684811b0 WHIRLPOOL fe34509a7a66d7e554fd84a1339758a57525771bea34db0433f503b334aa888556266e98967060acd07431412bab5ca5f87f6fefef3ca74cd692914923f40a73
diff --git a/dev-python/pymtp/metadata.xml b/dev-python/pymtp/metadata.xml
new file mode 100644
index 000000000000..566450e394eb
--- /dev/null
+++ b/dev-python/pymtp/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/pymtp/pymtp-0.0.6.ebuild b/dev-python/pymtp/pymtp-0.0.6.ebuild
new file mode 100644
index 000000000000..795dcede20c6
--- /dev/null
+++ b/dev-python/pymtp/pymtp-0.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="LibMTP bindings for Python"
+HOMEPAGE="http://packages.debian.org/libmtp http://libmtp.sourceforge.net/ http://pypi.python.org/pypi/PyMTP"
+DEB_URI="mirror://debian/pool/main/${PN:0:1}/${PN}"
+SRC_URI="${DEB_URI}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE=GPL-3
+SLOT=0
+KEYWORDS="amd64 ppc x86"
+IUSE="examples"
+
+RDEPEND="media-libs/libmtp"
+DEPEND=${RDEPEND}
+
+S="${WORKDIR}"/PyMTP-${PV}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}