summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyocr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyocr')
-rw-r--r--dev-python/pyocr/Manifest2
-rw-r--r--dev-python/pyocr/metadata.xml22
-rw-r--r--dev-python/pyocr/pyocr-0.2.4.ebuild24
-rw-r--r--dev-python/pyocr/pyocr-0.3.0.ebuild24
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/pyocr/Manifest b/dev-python/pyocr/Manifest
new file mode 100644
index 000000000000..bff45801fa0c
--- /dev/null
+++ b/dev-python/pyocr/Manifest
@@ -0,0 +1,2 @@
+DIST pyocr-0.2.4.tar.gz 309220 SHA256 a8db05190b505691a5c5fd1459072fda7f429940b562209b42f3db93c1292ef6 SHA512 8df6aa267743ae05864a0272764bfefc95c5071399ac90a7c0d52ec9fff65c55380066fad46412f71f6c7b2f8125e1b618fec6ecca4d7ff696c005115cd59d9d WHIRLPOOL 22efb3f668b9adc0e80a71b86d157252c4de8cee0d7628f1835b40d8892501871ba58ad6928dab97a76b66d66319bdbe43fe0a4cfa57d39b6216c673747b9dd3
+DIST pyocr-0.3.0.tar.gz 315750 SHA256 b17279f1961487d635dd43dbbf94c3cee678ab262812cf4d7b0bd919f960f13d SHA512 c5014026072d4a5edad2bf32817c07c09436aed0d2544aba6d1418dd6f0a238ee4794171922d5d473142ff21e5df97b27be6fe12c83124a39dd2c1f67445d6de WHIRLPOOL a6b10f313660b80c47ead6b0e6a426e3ce595dda23954c25675273ef5a7adc8abce626a964fc14eb12baa9b46e346e54c6dd49e91b2a92d4be68db8e07b5edde
diff --git a/dev-python/pyocr/metadata.xml b/dev-python/pyocr/metadata.xml
new file mode 100644
index 000000000000..11b6156c308f
--- /dev/null
+++ b/dev-python/pyocr/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <longdescription lang="en">
+Pyocr is an optical character recognition (OCR) tool wrapper for python. That is, it helps using OCR tools from a Python program.
+
+It has been tested only on GNU/Linux systems. It should also work on similar systems (*BSD, etc). It doesn't work on Windows, MacOSX, etc.
+
+Pyocr can be used as a wrapper for google's Tesseract-OCR or Cuneiform. It can read all image types supported by Pillow, including jpeg, png, gif, bmp, tiff, and others. It also support bounding box data.
+ </longdescription>
+ <use>
+ <flag name="cuneiform">Enable support for the <pkg>app-text/cuneiform</pkg> OCR engine</flag>
+ <flag name="tesseract">Enable support for the <pkg>app-text/tesseract</pkg> OCR engine</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">jflesch/pyocr</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyocr/pyocr-0.2.4.ebuild b/dev-python/pyocr/pyocr-0.2.4.ebuild
new file mode 100644
index 000000000000..53f9463043da
--- /dev/null
+++ b/dev-python/pyocr/pyocr-0.2.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="an optical character recognition (OCR) tool wrapper for python"
+HOMEPAGE="https://github.com/jflesch/pyocr"
+SRC_URI="https://github.com/jflesch/pyocr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+IUSE="cuneiform +tesseract"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="cuneiform? ( app-text/cuneiform )
+ tesseract? ( app-text/tesseract )
+ virtual/python-imaging"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="|| ( cuneiform tesseract )"
diff --git a/dev-python/pyocr/pyocr-0.3.0.ebuild b/dev-python/pyocr/pyocr-0.3.0.ebuild
new file mode 100644
index 000000000000..6f9516e3ef54
--- /dev/null
+++ b/dev-python/pyocr/pyocr-0.3.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="an optical character recognition (OCR) tool wrapper for python"
+HOMEPAGE="https://github.com/jflesch/pyocr"
+SRC_URI="https://github.com/jflesch/pyocr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+IUSE="cuneiform +tesseract"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="cuneiform? ( app-text/cuneiform )
+ tesseract? ( app-text/tesseract )
+ virtual/python-imaging"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="|| ( cuneiform tesseract )"