summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-10 17:15:26 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-10 17:15:33 +0100
commit329cf07554886e8a9a18c290a3822da34cc403ab (patch)
tree0dd7b3681d66e3e29e3ec5c265784fb8e70189c3 /dev-python/pyopencl
parentdev-python/pytools: Version Bump (diff)
downloadgentoo-329cf07554886e8a9a18c290a3822da34cc403ab.tar.gz
gentoo-329cf07554886e8a9a18c290a3822da34cc403ab.tar.bz2
gentoo-329cf07554886e8a9a18c290a3822da34cc403ab.zip
dev-python/pyopencl: Fix deps
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=574346 Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/pyopencl-2015.2.4.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/dev-python/pyopencl/pyopencl-2015.2.4.ebuild b/dev-python/pyopencl/pyopencl-2015.2.4.ebuild
index 82979731fc95..73512472d6cc 100644
--- a/dev-python/pyopencl/pyopencl-2015.2.4.ebuild
+++ b/dev-python/pyopencl/pyopencl-2015.2.4.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
+
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1
@@ -16,16 +17,19 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples opengl"
-RDEPEND=">=dev-libs/boost-1.48[python,${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
+RDEPEND="
+ >=dev-libs/boost-1.48[python,${PYTHON_USEDEP}]
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]
+ >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
dev-python/mako[${PYTHON_USEDEP}]
- dev-python/pytools[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2015.1.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
>=virtual/opencl-0-r1"
DEPEND="${RDEPEND}"
-src_configure()
-{
+src_configure() {
local myconf=()
if use opengl; then
myconf+=(--cl-enable-gl)