summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-03-18 22:11:34 -0400
committerRick Farina <zerochaos@gentoo.org>2020-03-18 22:11:58 -0400
commit6340061ed3c97189e0022065f99066561c4452d4 (patch)
treef3130d87207c9282a6778dac398b406eba45670d /dev-python/pyotherside/pyotherside-1.5.9.ebuild
parentapp-crypt/yubikey-manager-qt: adding python3_{7,8} (diff)
downloadgentoo-6340061ed3c97189e0022065f99066561c4452d4.tar.gz
gentoo-6340061ed3c97189e0022065f99066561c4452d4.tar.bz2
gentoo-6340061ed3c97189e0022065f99066561c4452d4.zip
dev-python/pyotherside: bump
adding python3_8 Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'dev-python/pyotherside/pyotherside-1.5.9.ebuild')
-rw-r--r--dev-python/pyotherside/pyotherside-1.5.9.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyotherside/pyotherside-1.5.9.ebuild b/dev-python/pyotherside/pyotherside-1.5.9.ebuild
new file mode 100644
index 000000000000..768b631a0b94
--- /dev/null
+++ b/dev-python/pyotherside/pyotherside-1.5.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit qmake-utils python-single-r1
+
+DESCRIPTION="Asynchronous Python 3 Bindings for Qt 5"
+HOMEPAGE="https://github.com/thp/pyotherside https://thp.io/2011/pyotherside/"
+SRC_URI="https://github.com/thp/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+# Requires active X display
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ "
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e "s/qtquicktests//" pyotherside.pro || die
+
+ default
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}