summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-04 15:59:15 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-04 16:01:48 +0100
commit1d9634f14b12fdc731701e9edb5458f64a79b3a4 (patch)
treeef216b91727f4384602400e2cd3ce3e27c2020ce /dev-python/pypy-exe
parentapp-admin/keepassxc: Removed old (diff)
downloadgentoo-1d9634f14b12fdc731701e9edb5458f64a79b3a4.tar.gz
gentoo-1d9634f14b12fdc731701e9edb5458f64a79b3a4.tar.bz2
gentoo-1d9634f14b12fdc731701e9edb5458f64a79b3a4.zip
dev-python/pypy-exe: Fix interpreter choice conditional
Closes: https://bugs.gentoo.org/704756 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypy-exe')
-rw-r--r--dev-python/pypy-exe/pypy-exe-7.3.0.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/dev-python/pypy-exe/pypy-exe-7.3.0.ebuild b/dev-python/pypy-exe/pypy-exe-7.3.0.ebuild
index 0b1e0997bb9..720c1dc86a9 100644
--- a/dev-python/pypy-exe/pypy-exe-7.3.0.ebuild
+++ b/dev-python/pypy-exe/pypy-exe-7.3.0.ebuild
@@ -70,20 +70,18 @@ pkg_setup() {
if [[ ${MERGE_TYPE} != binary ]]; then
check_env
- if has_version -b dev-python/pypy ||
- has_version -b dev-python/pypy-bin
+ use low-memory && local EPYTHON=
+ if [[ ! ${EPYTHON} || ${EPYTHON} == pypy ]] &&
+ { has_version -b dev-python/pypy ||
+ has_version -b dev-python/pypy-bin; }
then
- if [[ ! ${EPYTHON} || ${EPYTHON} == pypy ]] ||
- use low-memory
- then
- einfo "Using already-installed PyPy to perform the translation."
- EPYTHON=pypy
- else
- einfo "Using ${EPYTHON} to perform the translation. Please note that upstream"
- einfo "recommends using PyPy for that. If you wish to do so, please unset"
- einfo "the EPYTHON variable."
- python-any-r1_pkg_setup
- fi
+ einfo "Using already-installed PyPy to perform the translation."
+ EPYTHON=pypy
+ else
+ einfo "Using ${EPYTHON} to perform the translation. Please note that upstream"
+ einfo "recommends using PyPy for that. If you wish to do so, please unset"
+ einfo "the EPYTHON variable."
+ python-any-r1_pkg_setup
fi
fi
}