summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-22 09:29:32 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-22 12:50:52 +0100
commit2fe9e87dc3f33f52e7230421e0fe639904a53f6b (patch)
tree7ef727d563aa92835a7d01a8d03c6b6f1816cad7 /dev-python/pypy3
parentdev-python/pypy3-exe-bin: Bump to 7.3.3 (final) (diff)
downloadgentoo-2fe9e87dc3f33f52e7230421e0fe639904a53f6b.tar.gz
gentoo-2fe9e87dc3f33f52e7230421e0fe639904a53f6b.tar.bz2
gentoo-2fe9e87dc3f33f52e7230421e0fe639904a53f6b.zip
dev-python/pypy3: Bump to 7.3.3 (final)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypy3')
-rw-r--r--dev-python/pypy3/Manifest1
-rw-r--r--dev-python/pypy3/pypy3-7.3.3.ebuild207
2 files changed, 208 insertions, 0 deletions
diff --git a/dev-python/pypy3/Manifest b/dev-python/pypy3/Manifest
index 09c8da41a5db..1ecc12ed18f5 100644
--- a/dev-python/pypy3/Manifest
+++ b/dev-python/pypy3/Manifest
@@ -1,5 +1,6 @@
DIST pypy3.6-v7.3.1-src.tar.bz2 22712809 BLAKE2B 4250b3fe98c611b9635319c106b80e88ab469eab5f883babb738e175e7b7adc22c85f8ef3fdce1cdc127b521beef8d6c7862e188d8c8889c39f90136d6bbe374 SHA512 f8e32aae7f01225e0e4d6763eaac40fc02dffc3d0b6a30f22d422147f9be4f3290ea78160a912ffae311dea3d503eb31a7a4f3999d3b541fbccd93d1cef4ca56
DIST pypy3.6-v7.3.2-src.tar.bz2 22736022 BLAKE2B e2338ac3f7af06b987c43e93eab9ff14d46262143472b0393b30b011fff67d33add45d8198cee7109354e09c52a2540938abeef364b0cf12f2891ca9c7aac2a4 SHA512 ed861a57d6edf1548c061d10295313a05d0ac54fe68a8755211ff76fa2dc78d7b1479c6152dc5d0d1cdce4e247c240c1a2edf59ec8a53d0004ec7713514c9c35
+DIST pypy3.6-v7.3.3-src.tar.bz2 22484684 BLAKE2B a252e3070ec1c7cfd708cd694bd461d56241100463bac5ff7bbcf2d2667e01990ec8b4ceb947449ab1f620d0d5a8984bd8af3e2565555e5f73218e3c35ae1ebd SHA512 3bc9d9cc362f500e9e79c2694fc355706ac44d6dd5b8f5fb4d017d0997581472a9fdda08ccbe45469c7b52facdc0512be07843ba54d1d691fdb37f6628065879
DIST pypy3.6-v7.3.3rc1-src.tar.bz2 22401663 BLAKE2B 278b71a3b608999ee20b6558598eda453f3a87645965b8b705a11d05784722106c04b405375f62bd8e7ce2968df311314ee1672a2ddecb0f6afc49a3cbe8e670 SHA512 d865125925603e74412be7e750ab403670f05e76f2dfe6280c8b0ef123ed3e2f463d9457b65aa4f84c47a3529b2d3bca84b84307623bf995f60b549c85dcce2d
DIST pypy3.7-v7.3.2-src.tar.bz2 25060911 BLAKE2B 35ecfee4c64e13539827c65a61e0cd359de4046f77553629cdf63479327c6ad86afd1443caa7a911a6271f496f0f3caf1b919ce91de717d0a71d008927b7f77b SHA512 563a9cf63e818b95aeb14c25b55bb5fb0bf8283f0b9f2bdd9a8833989beb651681f53f52368fb9db2c75fb60be0456eec87d48b557740b57847c4104003cb288
DIST pypy3.7-v7.3.3rc1-src.tar.bz2 24511164 BLAKE2B 7fba1fde1bb248006f95fbb52dd9f237086f7221b99d6a288c1a32188a76ed76b1908e7f2054fd969b597c422c566214dd1e9ec409e243a776e8fa466fbf2039 SHA512 f98e7d209f75c4fa5645db16e1cc721ba80d44ad76030bd1c412800bb723ba528a83da89c8793a7e105d8391e72eeef7cb0198f9b30041178e90b628f14e5a3e
diff --git a/dev-python/pypy3/pypy3-7.3.3.ebuild b/dev-python/pypy3/pypy3-7.3.3.ebuild
new file mode 100644
index 000000000000..c0706600dea4
--- /dev/null
+++ b/dev-python/pypy3/pypy3-7.3.3.ebuild
@@ -0,0 +1,207 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit pax-utils python-any-r1 toolchain-funcs
+
+MY_P=pypy3.6-v${PV/_/}
+
+DESCRIPTION="A fast, compliant alternative implementation of the Python (3.6) language"
+HOMEPAGE="https://pypy.org/"
+SRC_URI="https://buildbot.pypy.org/pypy/${MY_P}-src.tar.bz2"
+S="${WORKDIR}/${MY_P}-src"
+
+LICENSE="MIT"
+# pypy3 -c 'import sysconfig; print(sysconfig.get_config_var("SOABI"))'
+SLOT="0/pypy36-pp73"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 gdbm +jit libressl ncurses sqlite test tk"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ || (
+ dev-python/pypy3-exe:${PV}[bzip2?,ncurses?]
+ dev-python/pypy3-exe-bin:${PV}
+ )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ gdbm? ( sys-libs/gdbm:0= )
+ sqlite? ( dev-db/sqlite:3= )
+ tk? (
+ dev-lang/tk:0=
+ dev-tcltk/tix:0=
+ )
+ !<dev-python/pypy3-bin-7.3.0:0"
+DEPEND="${RDEPEND}
+ test? (
+ ${PYTHON_DEPS}
+ !!dev-python/pytest-forked
+ )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ eapply "${FILESDIR}/7.3.1-gentoo-path.patch"
+ eapply "${FILESDIR}/1.9-distutils.unixccompiler.UnixCCompiler.runtime_library_dir_option.patch"
+ eapply "${FILESDIR}"/7.2.0-distutils-cxx.patch
+
+ sed -e "s^@EPREFIX@^${EPREFIX}^" \
+ -i lib-python/3/distutils/command/install.py || die
+
+ # apply CPython stdlib patches
+ pushd lib-python/3 > /dev/null || die
+ eapply "${FILESDIR}"/python-3.5-distutils-OO-build.patch
+ popd > /dev/null || die
+
+ # see http://buildbot.pypy.org/summary?branch=py3.6&builder=pypy-c-jit-linux-x86-64
+ sed -i -e 's:test_jumpy:_&:' \
+ lib-python/3/test/test_dis.py || die
+ sed -i -e 's:test_get_and_set_scheduler_and_param:_&:' \
+ lib-python/3/test/test_posix.py || die
+ sed -i -e 's:test_auto_history:_&:' \
+ -e 's:test_history_size:_&:' \
+ lib-python/3/test/test_readline.py || die
+ sed -i -e 's:test_eval_bytes_invalid_escape:_&:' \
+ -e 's:test_eval_str_invalid_escape:_&:' \
+ lib-python/3/test/test_string_literals.py || die
+ sed -i -e 's:test_jump_out_of_async_for_block:_&:' \
+ -e 's:test_jump_over_async_for_block_before_else:_&:' \
+ -e 's:test_no_jump_.*wards_into_async_for_block:_&:' \
+ -e 's:test_no_jump_into_async_for_block_before_else:_&:' \
+ -e 's:test_no_jump_from_yield:_&:' \
+ lib-python/3/test/test_sys_settrace.py || die
+ sed -i -e 's:test_circular_imports:_&:' \
+ lib-python/3/test/test_threaded_import.py || die
+
+ # the first one's broken by sandbox, the second by our env
+ sed -i -e 's:test_empty_env:_&:' \
+ -e 's:test_executable(:_&:' \
+ -e 's:test_executable_without_cwd:_&:' \
+ lib-python/3/test/test_subprocess.py || die
+
+ # XXX
+ sed -i -e 's:test_locale:_&:' \
+ lib-python/3/test/test_format.py || die
+ sed -i -e 's:test_decompressor_bug_28275:_&:' \
+ lib-python/3/test/test_lzma.py || die
+
+ eapply_user
+}
+
+src_configure() {
+ tc-export CC
+}
+
+src_compile() {
+ # copy over to make sys.prefix happy
+ cp -p "${BROOT}"/usr/lib/pypy3.6/pypy3-c-${PV} pypy3-c || die
+ cp -p "${BROOT}"/usr/lib/pypy3.6/include/${PV}/* include/ || die
+ # (not installed by pypy)
+ rm pypy/module/cpyext/include/_numpypy/numpy/README || die
+ mv pypy/module/cpyext/include/* include/ || die
+ mv pypy/module/cpyext/parse/*.h include/ || die
+ pax-mark m pypy3-c
+
+ einfo "Generating caches and CFFI modules ..."
+
+ # Generate Grammar and PatternGrammar pickles.
+ ./pypy3-c -c "import lib2to3.pygram, lib2to3.patcomp; lib2to3.patcomp.PatternCompiler()" \
+ || die "Generation of Grammar and PatternGrammar pickles failed"
+
+ # Generate cffi modules
+ # Please keep in sync with pypy/tool/build_cffi_imports.py!
+#cffi_build_scripts = {
+# "_blake2": "_blake2/_blake2_build.py",
+# "_ssl": "_ssl_build.py",
+# "sqlite3": "_sqlite3_build.py",
+# "audioop": "_audioop_build.py",
+# "tk": "_tkinter/tklib_build.py",
+# "curses": "_curses_build.py" if sys.platform != "win32" else None,
+# "syslog": "_syslog_build.py" if sys.platform != "win32" else None,
+# "gdbm": "_gdbm_build.py" if sys.platform != "win32" else None,
+# "pwdgrp": "_pwdgrp_build.py" if sys.platform != "win32" else None,
+# "resource": "_resource_build.py" if sys.platform != "win32" else None,
+# "lzma": "_lzma_build.py",
+# "_decimal": "_decimal_build.py",
+# "_sha3": "_sha3/_sha3_build.py",
+ cffi_targets=( blake2/_blake2 sha3/_sha3 ssl
+ audioop syslog pwdgrp resource lzma decimal )
+ use gdbm && cffi_targets+=( gdbm )
+ use ncurses && cffi_targets+=( curses )
+ use sqlite && cffi_targets+=( sqlite3 )
+ use tk && cffi_targets+=( tkinter/tklib )
+
+ local t
+ # all modules except tkinter output to .
+ # tkinter outputs to the correct dir ...
+ cd lib_pypy || die
+ for t in "${cffi_targets[@]}"; do
+ # tkinter doesn't work via -m
+ ../pypy3-c "_${t}_build.py" || die "Failed to build CFFI bindings for ${t}"
+ done
+
+ # Cleanup temporary objects
+ find -name "_cffi_*.[co]" -delete || die
+ find -type d -empty -delete || die
+}
+
+src_test() {
+ # (unset)
+ local -x PYTHONDONTWRITEBYTECODE=
+ local -x COLUMNS=80
+
+ # Test runner requires Python 2 too. However, it spawns PyPy3
+ # internally so that we end up testing the correct interpreter.
+ "${EPYTHON}" ./pypy/test_all.py --pypy=./pypy3-c -vv lib-python || die
+}
+
+src_install() {
+ local dest=/usr/lib/pypy3.6
+ einfo "Installing PyPy ..."
+ dosym pypy3-c-${PV} "${dest}/pypy3-c"
+ insinto "${dest}"
+ # preserve mtimes to avoid obsoleting caches
+ insopts -p
+ doins -r include lib_pypy lib-python
+
+ # replace copied headers with symlinks
+ for x in "${BROOT}"/usr/lib/pypy3.6/include/${PV}/*; do
+ dosym "${PV}/${x##*/}" "${dest}/include/${x##*/}"
+ done
+
+ dosym ../lib/pypy3.6/pypy3-c /usr/bin/pypy3
+ dodoc README.rst
+
+ if ! use gdbm; then
+ rm -r "${ED}${dest}"/lib_pypy/_gdbm* || die
+ fi
+ if ! use sqlite; then
+ rm -r "${ED}${dest}"/lib-python/*3/sqlite3 \
+ "${ED}${dest}"/lib_pypy/_sqlite3* \
+ "${ED}${dest}"/lib-python/*3/test/test_sqlite.py || die
+ fi
+ if ! use tk; then
+ rm -r "${ED}${dest}"/lib-python/*3/{idlelib,tkinter} \
+ "${ED}${dest}"/lib_pypy/_tkinter \
+ "${ED}${dest}"/lib-python/*3/test/test_{tcl,tk,ttk*}.py || die
+ fi
+
+ local -x EPYTHON=pypy3
+ local -x PYTHON=${ED}${dest}/pypy3-c-${PV}
+ # temporarily copy to build tree to facilitate module builds
+ cp -p "${BROOT}${dest}/pypy3-c-${PV}" "${PYTHON}" || die
+
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
+ python_moduleinto /usr/lib/pypy3.6/site-packages
+ python_domodule epython.py
+
+ einfo "Byte-compiling Python standard library..."
+ python_optimize "${ED}${dest}"
+
+ # remove to avoid collisions
+ rm "${PYTHON}" || die
+}