summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-25 12:06:47 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-25 12:07:00 +0200
commit2789272306f626ebce22604d0e741724f6f522e7 (patch)
tree6318e4fed059bb5b7efc175779b625321f39c544 /dev-python/pyquery/pyquery-1.2.9-r1.ebuild
parentdev-python/cssselect: Drop pypy support again due to unsatified deps (diff)
downloadgentoo-2789272306f626ebce22604d0e741724f6f522e7.tar.gz
gentoo-2789272306f626ebce22604d0e741724f6f522e7.tar.bz2
gentoo-2789272306f626ebce22604d0e741724f6f522e7.zip
dev-python/pyquery: Drop optional dep to optfeature
Package-Manager: portage-2.2.21 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pyquery/pyquery-1.2.9-r1.ebuild')
-rw-r--r--dev-python/pyquery/pyquery-1.2.9-r1.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/dev-python/pyquery/pyquery-1.2.9-r1.ebuild b/dev-python/pyquery/pyquery-1.2.9-r1.ebuild
index 1344a4c7380..580a69588fa 100644
--- a/dev-python/pyquery/pyquery-1.2.9-r1.ebuild
+++ b/dev-python/pyquery/pyquery-1.2.9-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-inherit distutils-r1
+inherit distutils-r1 eutils
DESCRIPTION="A jQuery-like library for python"
HOMEPAGE="https://github.com/gawel/pyquery"
@@ -15,23 +15,28 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
-IUSE="beautifulsoup3 test"
+IUSE="test"
-RDEPEND=">=dev-python/lxml-2.1[beautifulsoup3?,${PYTHON_USEDEP}]
+RDEPEND="
+ >=dev-python/lxml-2.1[${PYTHON_USEDEP}]
>dev-python/cssselect-0.7.9[${PYTHON_USEDEP}]
>=dev-python/webob-1.1.9[${PYTHON_USEDEP}]"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
app-arch/unzip
test? ( ${RDEPEND}
+ dev-python/beautifulsoup:python-2[$(python_gen_usedep 'python2*')]
+ dev-python/beautifulsoup:python-3[$(python_gen_usedep 'python3*')]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/webtest[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/restkit[${PYTHON_USEDEP}]' 'python2_7') )"
-REQUIRED_USE="test? ( beautifulsoup3 )"
-
python_test() {
# The suite, it appears, requires this hard setting of PYTHONPATH!
PYTHONPATH=. nosetests || die "Tests fail with ${EPYTHON}"
}
+
+pkg_postinst() {
+ optfeature "Support for BeautifulSoup3 as a parser backend" dev-python/beautifulsoup
+}