summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-05-18 06:00:24 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2018-05-18 06:00:24 -0400
commit96d3c211caaf26df43ecb884cf20efa65e5e0879 (patch)
treea73bd30f4a53ea96f22b7cee728231da7e8a5e1e /dev-python/pyrsistent
parentdev-libs/libpcre: mark 8.41-r1 m68k/s390/sh stable (diff)
downloadgentoo-96d3c211caaf26df43ecb884cf20efa65e5e0879.tar.gz
gentoo-96d3c211caaf26df43ecb884cf20efa65e5e0879.tar.bz2
gentoo-96d3c211caaf26df43ecb884cf20efa65e5e0879.zip
dev-python/pyrsistent: Bump to 0.14.2
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python/pyrsistent')
-rw-r--r--dev-python/pyrsistent/Manifest1
-rw-r--r--dev-python/pyrsistent/pyrsistent-0.14.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyrsistent/Manifest b/dev-python/pyrsistent/Manifest
index d37948c49690..c3965959de44 100644
--- a/dev-python/pyrsistent/Manifest
+++ b/dev-python/pyrsistent/Manifest
@@ -1 +1,2 @@
DIST pyrsistent-0.13.0.tar.gz 96326 BLAKE2B 47388d7d48841c3a093c5309e20e92619b16c9f7c59a47929b8504a7e6aed803cb1fa07260ef8fbc5ebb4b243a52329a5a9976ca947c00243fc5dd3bc9e34e8a SHA512 6bfb657841382c4ad402c383cae5092b83e93a3dde0b905f6cb8ca8a50b8acbe0f3241e9cc50cb83892c0d59b13145764faa2a3db1eabecbe6606a35d07bb5ff
+DIST pyrsistent-0.14.2.tar.gz 97650 BLAKE2B 343990acbd1cd566a410508514393b6e3c4cf074bb2f1bb46404cd64af05a7397c3abc357ecc29fc82b9fd390f567ba4fa4a3c9c6dd52045f40f28fc7eaa97f7 SHA512 06ae1b9d15ac72b09d2fdb80e28849a105cd6955f206472649996318c2dc9915f251d76908a913c02d5583e1e818ff456af496b13fe9b094c043cd2548b2b6d5
diff --git a/dev-python/pyrsistent/pyrsistent-0.14.2.ebuild b/dev-python/pyrsistent/pyrsistent-0.14.2.ebuild
new file mode 100644
index 000000000000..8ad89c3eb6a4
--- /dev/null
+++ b/dev-python/pyrsistent/pyrsistent-0.14.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Persistent/Functional/Immutable data structures"
+HOMEPAGE="https://github.com/tobgu/pyrsistent/ https://pypi.org/project/pyrsistent/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+# https://github.com/tobgu/pyrsistent/issues/
+# fails
+#RESTRICT="test"
+
+python_test() {
+ export PYTHONPATH="${S}:${PYTHONPATH}"
+ py.test -v -v -x || die ${PYTHONPATH}
+}