summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-10-14 23:56:18 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-10-14 23:56:18 -0500
commit55a9a24b014bd812b07c0ee80009e25518608910 (patch)
treed3fe4215dead99481ca09e3868d9bfb0afc16fbf /dev-python/pysaml2
parentdev-python/repoze-who: adding py34 support (diff)
downloadgentoo-55a9a24b014bd812b07c0ee80009e25518608910.tar.gz
gentoo-55a9a24b014bd812b07c0ee80009e25518608910.tar.bz2
gentoo-55a9a24b014bd812b07c0ee80009e25518608910.zip
dev-python/pysaml2: bup with py34 support
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/pysaml2')
-rw-r--r--dev-python/pysaml2/Manifest1
-rw-r--r--dev-python/pysaml2/pysaml2-3.0.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pysaml2/Manifest b/dev-python/pysaml2/Manifest
index 36740ed32334..b69cb6e5448a 100644
--- a/dev-python/pysaml2/Manifest
+++ b/dev-python/pysaml2/Manifest
@@ -1 +1,2 @@
DIST pysaml2-2.1.0.tar.gz 12697706 SHA256 0843cbe784fd3b8b798d8b476fe871d48f0f2aab2bd95036a6e50eda99860340 SHA512 ba2076bd81465f3bbaeac11e9a6908f1ab899aa301c909b6bc67a681e94a7260ab214bad949dc937b4673bbed2aa550bf196ee8b055939fce62c628056df18ac WHIRLPOOL beee7908e4bec5512c3a7c11fb94dfdbf2dfe284bffd86ec487100f81129928e1dc1512aed054939eedcb79205e32690b21f3fd50d768cef1ad4decfd00ba75b
+DIST pysaml2-3.0.0.tar.gz 13051759 SHA256 22aec520b3324f1f33cad58862f03ec3e000b2abc36880a5202615ba9fda5cc0 SHA512 a16281888e86222204dbabcec1501d3d2ef6374ad63225f60664a663f2aad6dd2ffe9d8e77f7f1fc18fefc12a4ba44d183ed04c201774ad9e174fd604b91bb78 WHIRLPOOL 7814d31852144c6bf9de8581e7cbc1d7d11bb337d53b828022a5a956615acdd1f3ad4ee79dbb8632a0a80c17dc6119ea31f54734ed5afd254f77eb05ea2ab63d
diff --git a/dev-python/pysaml2/pysaml2-3.0.0.ebuild b/dev-python/pysaml2/pysaml2-3.0.0.ebuild
new file mode 100644
index 000000000000..8d050f7c6271
--- /dev/null
+++ b/dev-python/pysaml2/pysaml2-3.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of SAML Version 2 to be used in a WSGI environment"
+HOMEPAGE="https://github.com/rohe/pysaml2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.0.0[${PYTHON_USEDEP}]
+ dev-python/paste[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/repoze-who[${PYTHON_USEDEP}]
+ >=dev-python/pycrypto-2.5[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"